What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Endstop Z and probe always Triggered

Death69

Member
Printer Model
Voron V2.4r2
Hi,

I have a Z Endstop Switch installed and Klicky Probe installed. From Mainsail I can see that Endstop Z and Probe always Triggered.
When manually pressing the Z Endstop Switch, nothing happens. Where it says "probe" is it referring to the klicky probe or the hot-end?
klicky probe is installed on PIN PB7 (J40) and Z Endstop Switch on PIN PG10 (J31) which has been replaced in the printer config file with endstop_pin: probe:z_virtual_endstop
zip file contains printer cfg and all of klicky config files.

Klipper Z-Calibration on github refers to this youtube video:
For me to follow that video, I need to get klicky probe working.

Thanks
 

Attachments

  • Config.zip
    23 KB · Views: 3
I have tried that, it did not work. The picture shows what I see with and without the "!".
I just want to make sure the all the configuration files look good before I dismantle the printer.
 

Attachments

  • 1.jpg
    1.jpg
    15.2 KB · Views: 2
I don't recall the setup you need since mine is much differant but here is from the Klipper docs,
What I would look at is trying to add the pullup to the config like this ^!PB7 or ^PB7 or ~!PB7

Format of micro-controller pin names

Many config options require the name of a micro-controller pin. Klipper uses the hardware names for these pins - for example PA4.

Pin names may be preceded by ! to indicate that a reverse polarity should be used (eg, trigger on low instead of high).

Input pins may be preceded by ^ to indicate that a hardware pull-up resistor should be enabled for the pin. If the micro-controller supports pull-down resistors then an input pin may alternatively be preceded by ~.
 
All of these should be changed or only the enable_pin:?
step_pin: PF11
dir_pin: PG3
enable_pin: PG5

Change to:
step_pin: ^PF11
dir_pin: ^PG3
enable_pin: ^PG5
 
After changing the config file and adding the ~ to PB7, Everything is now "open".
However, when manually triggering the Klicky Probe or the Z endstop it remains open.

#####################################################################
# Probe
#####################################################################

## Inductive Probe replaced with Klicky Probe
## This probe is not used for Z height, only Quad Gantry Leveling
[probe]

#--------------------------------------------------------------------

## Select the probe port by type:
## For the PROBE port. Will not work with Diode. May need pull-up resistor from signal to 24V.
#pin: ~!PB7
## For the DIAG_7 port. NEEDS BAT85 DIODE! Change to !PG15 if probe is NO.
pin: ~PB7
## For Octopus Pro PROBE port; NPN and PNP proximity switch types can be set by jumper
#pin: ~!PC5

#--------------------------------------------------------------------

x_offset: 0
y_offset: 19.75
z_offset: 6.42
speed: 10.0
samples: 3
samples_result: median
sample_retract_dist: 5.0
samples_tolerance: 0.006
samples_tolerance_retries: 5
 
I changed the probe pin to PG15 and now it works correctly.
New problem: When manually triggering the Klicky Probe; both the Klicky Probe and the Z endstop trigger together.
When manually triggering the Z endstop, nothing happens.
 
Last edited:
That was the first thing I checked. I have attached a new config file.
i have a strange suspicion that it has something to do with endstop_pin: probe:z_virtual_endstop
Maybe it's in the wrong place, or something else is going on.
 

Attachments

  • config-20240614-080751.zip
    9.9 KB · Views: 1
Last edited:
I have cleared the error.
stepper_z is set to endstop_pin: !PG10
Probe is set to pin: PG15

The problem was the endstop_pin: probe:z_virtual_endstop
 
Top