What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

2.4 canbus not extruding during print, but perfectly during tests


New member
Printer Model
Extruder Type
LGX Lite
Cooling Type
Recently switched to canbus on my perfectly working Voron 2.4. With an U2C 2.1 and EBB36 1.2 and an LGX Lite . Worked fine at beginning.

The problem I have is simple, it extrudes perfectly when it prints the start line I had put in the start_print macro, or even when I extrude manually with Fluidd, or even on Klipperscreen. No problem at all when I do like that, but during real beginning of print, it doesn’t do anything more than oozing what remains in the nozzle.
I checked everything It’s not a mechanical issue, or wiring, and it would not extrude normally during tests if it was the case.

I tested with known good sliced stls, tried slicing other ones etc etc, tested so many things I can’t list them. And there was no change at all in the config between working config, and now. Only klipper and fluidd updates.

I also have random klipper shutdowns due to EBBCan loosing connection, but only during homing or QGL, but never during print.

Just in case it helps can is wired with an Igus Chainflex cable, so a good quality and twisted one.

If you can see anything in the klippy log, I would be so thankfull!!
Here is the direct link to it if you want to have a look

Edit: also forgot to say, I tried canbus speeds from 250000 to 1000000. No change

And last one, the emergency shutdown is wanted, I done it just after another printing test, to make the problem more easy to “read” in the klippy log
Ok, lets check the basics.

Did you terminate the can bus resisters on the ebb36 (assuming it's the last device on the chain)?

You are sure the EBB36 MCU, RPI, U2C are all set to the same can bus speed / data rate?

Please post your /etc/network/interfaces.d/can0 (or whatever your can network is called).

Have you installed can utils on the RPI?

What does ip -details -statistics link show can0 show around the time of the failure?

Does canbusload can0@YourCANSpeedHere -b -c ever peak above 30% ?

Does your RPI go over 50% processor utilization while probing or when the can bus has your heaviest use?

Have you bypassed the chain flex cable and used a twisted pair temporarily to rule out the cable/connectors?

Is your U2C plugged into USB 2.x or USB 1.x on the RPI?

Have you tried reflashing both the U2C and the Ebb36?

Are they running the same version of klipper?
Last edited: