What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Solved Cannot Connect to Moonraker


New member
I swapped / upgrade my gateway -- both pi's connected to the new gateway with same SSID no problem and Mainsail was working as expected. I was installing a new display for printer -- when adding the [display] into my config it required a MCU reflash. Prior to doing so I upgraded klipper and moonraker to the latest version, then reflashed MCU. Screen is working, and able to jog printer around through it, but unable to access Mainsail. Researching it seemed like it was ipv6. I have disabled ipv6 on the pi -- no luck. I then disabled ipv6 on my gateway -- still no luck. Any suggestions on next steps to resolve this moonraker / network issue?



  • moonraker.log
    64.3 KB · Views: 21
update -- got some pointers. will be backing up config files and following the manual moonraker setup (https://docs.mainsail.xyz/setup/manual-setup/moonraker) tomorrow. if all fails, then i'll reflash the pi with new image.

sounds like the issue was the moonraker update failing to install correctly.

admins -- new to this will there be flair/tags to mark items complete or anything?
That feels like a great idea - a resolved tag would be nice so people looking for similar problems can easily find related threads that resolved it.
Since you're trying to connect to a moonraker on a remote device, I'd check if your browser can even reach the moonraker API server by visiting it. In your case, that is likely If you get a page that says "Welcome to Moonraker" then at least your networking is fine. At that point, it is likely a CORS issue.

If you don't see the page at all you can try a few things, you'll want to make sure the IP is correct and that moonraker is running on the device. Typically sudo systemctl status moonraker.service can tell you if moonraker is successfully running.