What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Klipper reports mcu 'mcu': unable to connect


New member
nube's new install voron 0.1 with fysetc cheetah V1.1b
the mb has a ch340 so I don't get a serial # (i think)
the path entry in printer.cfg

i can connect to moonraker via <ip:7125> thats where I get the message to fix the underling issue. it says to check the paths plural is there another one I should check ?
I found something on the discord that said issue solved that said to edit the klipper envelope
and change serial to UDS. that changed so klipper kind of appeared to be working but still nothing between klipper and MCU.
Started over again with octoprint and klipper > same issue> I have a revo hotend and edited the thermistor type to "Semitec 104NT-4-R025H42G"
I noticed that this was white in the printer.cfg so I changed it back to the default and suddenly I was connected
It's really hard to say what did and didn't fix the problem without seeing the configuration files before it changed and what errors it was giving.
I've reloaded again with mainsail via rpi imager - still no mcu
edited the extruder thermistor and it connects , but all of the apps (mainsail ,crowsnest etc ) are listed as unknown or invalid in the update manager
oops forgot to run that first, will try again.
when I enter the thermistor as "ATC Semitec 104NT-4-R025H42G" it appears to accept it ,just doesn't connect
I first tried "Semitec 104NT-4-R025H42G" and got an error .
I've had another go at constructing printer.cfg . it connects . although I'm sure something will be wrong.
I based it on the Voron 0.2 ones posted which are all sensorless homing. I've no idea what my Diag pins are (cheetahV1.1b) I'm assuming I need to know
for sensorless homing ? . I 'm just starting testing


  • klippy.log
    82.6 KB · Views: 8