What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

(New build) Erratic XY movement and vibration when homing

YALE70

New member
Printer Model
Voron 2.4R2 250
Extruder Type
Clockwork 2
Cooling Type
Stealthburner
Hi all,

I'm close to finishing my first Formbot 2.4R2 250mm build and have started testing things out before I pop the panels on. I'm running into a pretty nasty issue with XY motion while attempting to home. It will drop Z slightly, then when homing X, the printer moves in a rough diagonal to the front right corner before hitting the endstop, while the opposite happens with Y: it moves towards the back left corner before hitting the endstop. Occasionally it may throw a "no trigger after full movement" error after contacting the microswitch. None of this motion is controlled and it causes a ton of vibration. It's almost like the steppers are "fighting".

Here's it attempting to home X:


What might be the culprit here? I don't want to make any assumptions since I'm a total rookie when it comes to assembling one of these machines, but as far as I can tell, the X and Y motion feels fine by hand and I don't see any binding on any of the idlers/pulleys that might cause it to seize. Adjusting the belt tension seems to have little effect as well. Hopefully it's just a simple oversight.

I am running a Manta M8P + CB1 with an EBB SB2209 (RP2040 and I have Moons MS17HD6P420I-05 stepper motors. My config is attached.
 

Attachments

  • printer.txt
    14.3 KB · Views: 4
Hi, first things first: Can you post pictures from the back of the gantry? Let's check if your belts are routed correctly. It's pretty common to route those through plastic parts instead of bearing stacks.

Second, make sure you downloaded the correct configuration file. Voron github has pre-made configuration files, if yours are from somewhere else but official repository, check if you have printer kinematics set to CoreXY in printer.cfg.

If you follow official documentation, it will guide you through the process of preparing your printer for the first print. https://docs.vorondesign.com/build/startup/
 
What Sanity said. Just to add, sounds like you need to invert one or more of the motors to get the direction correct. You can do this by adding or removing ! to your DIR pin.
 
Hi, first things first: Can you post pictures from the back of the gantry? Let's check if your belts are routed correctly. It's pretty common to route those through plastic parts instead of bearing stacks.

Second, make sure you downloaded the correct configuration file. Voron github has pre-made configuration files, if yours are from somewhere else but official repository, check if you have printer kinematics set to CoreXY in printer.cfg.

If you follow official documentation, it will guide you through the process of preparing your printer for the first print. https://docs.vorondesign.com/build/startup/
What Sanity said. Just to add, sounds like you need to invert one or more of the motors to get the direction correct. You can do this by adding or removing ! to your DIR pin.
Belts look like they're routed fine, but I attached pictures just in case.

My config is based off the official Voron one for the M8P, with the necessary changes for the EBB among others. Kinematics are set to "corexy".

I did end up sending STEPPER_BUZZ on the X and Y motors, and I found that while they both move in the correct direction (clockwise than back counter-clockwise), the X motor moves with significantly more "snap" than than Y motor. The Y motor looks like it's rotating slower. I gave the belts full slack just to eliminate tension as a potential factor and they still behave the same. They are configured with the same parameters:
microsteps: 16
rotation_distance: 40
full_steps_per_rotation: 200
Could this be an issue with the one stepper or the other? Or perhaps the driver, or board?

EDIT: I went ahead and plugged the Y stepper into the X stepper's driver and ran STEPPER_BUZZ on it. Still moves exactly the same as before, so I'm leaning towards it being a motor issue rather than a board/driver issue.
 

Attachments

  • 20240325_105040.jpg
    20240325_105040.jpg
    684.4 KB · Views: 8
  • 20240325_105015-min.jpg
    20240325_105015-min.jpg
    489.6 KB · Views: 9
Last edited:
Those are pretty good motors. Can you swap the motor wires with another motor to see if its the wires?
Did that. I plugged the suspect motor into the X driver with it's respective cable and got the same results, so it doesn't appear to be a driver or wiring related fault.

But...
This isn't the problem... but looking through your config... note that the Klipper docs recommend NOT using the interpolation feature in the TMC stepper configuration, as it introduces small position inaccuracies.
I changed this setting, and holy crap - it actually homed successfully. I don't know why, but this worked. Crisis averted (at least until the next one).

Thanks everyone!
 
I changed this setting, and holy crap - it actually homed successfully. I don't know why, but this worked.
Well... that was unexpected! 😁 Glad it helped though!


The Klipper docs only speak of comparatively minor artifacts... the example configuration giving position errors of ~0.006mm. Certainly not of the magnitude that you were seeing.

Hmmm....

I wonder if that means something else is/was mis-configured with those drivers? :unsure:
 
Top