What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Probe readings trending upwards


New member
Printer Model
2.4r2 350mm
Extruder Type
Clockwork 2
Cooling Type

I'm currently having an issue where my probes are trending upwards. It's relatively minor, but I just can't figure out what could be causing it. Over ~100 samples, it increases by about 0.02mm. Over 10 probes, I get a sample standard deviation of ~0.005mm, which seems pretty good (albeit out-of-spec). In general, I can start a print and get very good results, but I have to baby it through my print_start macro because of the probing, which fails about 1 in 5 times. And by baby, I just mean restart the print until it works.

The voron docs (Probe Accuracy Check) mentions "Make sure that the sensed distance is not trending (gradually decreasing or increasing over the 10 probes) and that the standard deviation is less than 0.003mm." but it doesn't actually say what to do if you're trending in one direction.

I'm currently running a 2.4r2 350mm, Stealthburner (with the AB X-axis mount because I was too lazy to swap it out when SB came out and I found that M3 nuts press fit nicely into the back of that mount which made it compatible), and a Euclid probe. LDO steppers for Z-axis. 1.1 A run current, stealthchop_threshold = 9999 (on).

I've been running my 2.4r2 for about 18 months now, and probing has always been an issue. I built before SB (and therefore tap), initially with the Omron inductive probe. That worked really well, but eventually the probe failed after about 6 months. Fortunately, I had anticipated it, and printed a Klicky. I never got consistent results with Klicky, and realized it was that the wires weren't making good contact with the magnets for conduction, but I couldn't get that to work--so I sidestepped it by switching to Euclid and have had pretty good results ever since. BUT, I'm noticing the problem seems to be getting worse, so I want to try to figure it out while my only printer is still working.

Any help would be appreciated!
So, I've spent the week since I posted trying to troubleshoot (or at least, spent my limited free time). In the interest of helping people that might have this issue in the future, I'll post what I've found so far.

From what I can tell, there are/were at least 3 (!) problems that I'm surprised meant I could print anything at all.

Tl;dr: Z-belts were loose, D2F-5 switch partially failed on Euclid, and I suspect that I need to work on a Z-drive but my printer is running much, much better.

First thing--easiest thing--was to turn off stealthchop--which did basically nothing. Still, I never turned it back on because I didn't seem to need it anyways.

I was putting off one of my upgrades in the first place until I figured this out, but I didn't have many ideas so I did it anyways--the hartk GE5C Z-axis mod. While doing this, I noticed my Z-axis belts were kind of loose. Certainly I could have tightened the belts without the mod, but I didn't want to tighten them, to loosen them, mod it, and re-tighten. It introduces a new potential issue, but I decided it was worth it. And... it got significantly better! I suspect my Z-axis belts were too loose.

However, when I did large samples of probe_accuracy, my sample standard deviation was outside the spec (>0.003 mm). I couldn't detect any trending like I could before, but I still wasn't happy with the sample noise.

I was able to print a few things though, although I noticed my print_start macro failing more often than it was before. Now, it was failing about half the time (maybe more?)--kind of weird for having seemingly improved my big issue. However, even with the failures, when it did print, prints were great. Back to troubleshooting.

So, I started another print, sure it was going to fail, and walked over to the printer. I watched it to see if I could visually observe anything obvious, and I didn't see much at first. I cancelled the print from my phone--not sure why I hadn't been using it anyways--and decided to run QGL multiple times to see what was going on. I started to notice something, which was the light flickering on my Euclid probe! So, something was wrong with the probe!

I pulled the probe out and looked at it, nothing obvious on the two PCBs, so I had to get the wiring out. I don't have a toolhead PCB, I'm using all microfit connectors shoved under the shroud. So, I pulled off the extruder and hotend to get the probe wiring out to look at it, and found that the signal socket wasn't fully seated in the microfit connector that goes to adapter cable. Not much effect, although there was definitely an issue. I tried a few other things with the cable as well, ultimately re-pinning the JST XH connector on the end entirely. No help.

I wasn't sure what to do at this point. The issue seemed to happen on running a probe, and was generally close, but not quite at, the proper Z-value. So, I was pretty sure that the problem was near the toolhead, and not by the control board; and it probably wasn't in the length of the harness either (if it was, the failure would just be intermittent). With the harness at the toolhead effectively re-pinned, I was a bit stumped.

I played around with the probe and my multimeter, and noticed that I could partially trigger my switch! Unfortunately, I misplaced my desoldering tools (mainly, my solder sucker), so I had to order a new one which arrived today.

Fortunately, I have a small stock of microswitches, and I replaced the switch on the probe earlier this evening. After doing that... my probing seems MUCH better!

A quick sample (10 runs) gave me a sample standard deviation of just under 0.003 mm. But, one of the things I noticed most was that it was much, much more stable! A run of probe_accuracy might give my 8-9 probes in a row which were identical. Which, revealed another issue. When I ran a larger sample, I could start to see a trend. I'm still trending upwards in probes, but the range is about an order of magnitude smaller. I suspect that there's still something wrong, and I'm not quite sure what, I think I couldn't see it because of the issue with the microswitch on the probe. My gut says that one of the Z-axis motors is slipping; not sure if it's a motor issue, driver issue, slack in the short transfer (not sure what the name of it actually is?) belt that connects the Z-axis motor to the larger belt-drive. But, I think my Z3 (front-left) drive is causing most of the issues; I've noticed a bit more of the other probing issues in that corner of the bed than anywhere else. I'm figuring out how to quantify it, but I'll look into it further when I can.

For the purposes of comparison, currently, my 100-sample run gave a range of 0.01375 mm and a standard deviation of 0.001779 mm. Given the sample deviation is about an order of magnitude less than the range, I still believe that there's an issue with the trending, but overall it seems like it should be good enough for now. Manually reviewing the numbers, there definitely seems to be a trend upwards as before, but still not much and probably not enough to consistently cause issues.