What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

software installation of btt octopus stm32f407 issue


I'm a newbie- I followed the Voron 2.4 software installation to a btt octopus- using the setup for the stm32f407 (32k, 8 Mhz, usb on pa11,pa12..)
When I uploaded via and SD card, and checked the serial id ($ls /dev/serial/by-id)
I got this:

Which references the F429???? I can only access this for a couple of seconds, then the "serial" directory goes away. (I definitely have an STM32F407 - as written on the chip)

Any help is greatly appreciated!
Well, that also says "marlin" so it's clearly not the firmware you tried to load. The stock firmware must not distinguish between the 407 and the 429
I had a few issues loading firmware on my Ocotopus board - think it may be a bit picky about the SD card - have you tried another card?
Thanks- I didn't even notice the Marlin part. How is that possible? The board definitely updated when I plugged in the SD card (all the green lights eventually turned off) so something programmed- how could it program wrong- but still reference a processor and board? This is very strange.
Honestly, I can't speak to what the lights did, but I'm quite confident what you're seeing there is the stock firmware it came out of the box with.

I always find sd based flashing a bit issue prone. My suggestion would be to follow the dfu flashing process, also seen in the voron docs (as option b).

Unfortunately, there is a slight challenge there: there's a compatability issue with the version of dfu-util on mainsailos, and the 429 (which I think will also impact your much less common 407). if you run "dfu-util -V", and it tells you that it's version 0.9, I'd suggest this fix, courtesy of clee:

upgrade to dfu-util v0.11 with the following commands over SSH/putty:

curl -LO http://raspbian.raspberrypi.org/raspbian/pool/main/d/dfu-util/dfu-util_0.11-1+b5_armhf.deb

sudo dpkg -i dfu-util*deb

this should allow the F429 to be flashed over DFU
Thanks again for the info. I ran your command and yes I was at version .9. I then ran your fix, now I see I am at v .11. I am unable to get the dfu of the device using lsusb command. I assume that since I can read the serial ids that the USB must be working. Any other help is greatly appreciated! Oh, I did try multiple SD cards - just in case without the boot0 jumper. No change.
So, just to review, you

1. Powered down
2. Installed the boot0 jumper
3. Powered up
4. Pressed reset on the octopus
5. Ran lsusb

And what DID you see in lsusb at that point?
After step 5 above (no SD card installed), I got:

Bus 001 Device 008: ID 0bda:b711 Realtek Semiconductor Corp. RTL8188GU 802.11n WLAN Adapter (After Modeswitch)
Bus 001 Device 003: ID 0424:ec00 Microchip Technology, Inc. (formerly SMSC) SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Microchip Technology, Inc. (formerly SMSC) SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
pi@mainsailos:~/klipper $
That doesn't seem like a bootloader issue(since dfu is burned in at the factory, it's not part of the regular bootloader) That seems like a "the board isn't present" issue. I'd check for bad usb cables, and other wiring issues that might be preventing the octopus from firing up (I'd strip back all wiring other than the power in & usb)
I appreciate the help. Yes, I checked 2 usb cables- both from the same place. I might purchase one- weird part is I do get dfu feedback only for a few seconds after pressing reset on octopus. That's how I read the marlin info. Then it's gone. This is repeatable every time. I have stripped this down to just 24V in and USB cable and made sure I have the correct filename when using the SD card (firmware.bin). Very strange- I am anxious to get printing!
That definitely sounds like something odd is happening. The board should just sit in dfu until its told to do something else.

How is your pi powered? Aka if the octopus was actually loosing power, would the pi die as well? Or keep running?
My pi is powered from an independent 5V power supply (which is powered from 120VAC). I was thinking maybe my PI USB is down? I tried different sockets- all the same. Still curious why the SD doesn't work either... The octopus has several green lights in the middle of the board. After about 1 minute, they turn off, one at a time. 3.3V LED is on all the time.
Octopus always off of 24V power. So when I take the octopus down, the pi goes down too. (both are connected to power supplies connected to 120V switch)
so it feels to me like your octopus is loosing power.
1. Do you have the usb power jumper installed?
2. once the octopus has vanished, and most of the lights go out, what is the green LED on the 24V PSU doing?
I double checked- the V_FUSED jumper is installed in J38 (bottom right corner of board). The 24V PSU green light is on the whole time.
I think power might be the problem- I downloaded the datasheet and PCB layout. I disconnected all my motor drivers (forgot they were still plugged in). Now no green lights come on- only 3 RED LEDs are on.: D31 (VCC-12V), D51 (3V3) and D39 (WORK-LED??). Looking at the schematic, there is a green led (D29) connected to the PWR_GD output of the 5.0V switcher. This is not on. I checked on J74 - 5V and 3V3 are good.

Do you have any lights on besides the 3 red ones I listed? I have no green leds lit on the board.
So I checked the 3V3 power - it was at 3.3V when the TMC2209s were all removed- and went down to .2V when they were inserted!
I was able to communicated with boot0 with them removed. Still couldn't download over SD card (without boot0 jumper). All this time it was the TMC2209s!! Not sure why they are bad. Ordering new ones now.

Thanks for your help- it really kept me motivated and prevented me from chucking this into the street! :)
an entire set of bad 2209s? thats just...bizarre

But I'm very glad you were able to run it down!