What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Voron 2.4 first build UART setup help

Printer Model
Voron 2.4 r2
Extruder Type
Clockwork 1
Cooling Type
Hello all, be gentle :)

First Voron build 2.4 r2 mostly 350mm. I have an old CR10 (for years) and a TRONXY S5A.

Decided to jump into a Voron 2.4 for all the right reasons. I have been toiling to get the build ready to flash and test. Kit was Fysetc

I have bits of a few kits and a few other parts I decided on like a light gantry, 3D printed SB toolhead, Toolhead board, etc... Have done all the connecting and wiring and the build is pretty much complete.

I am stuck on an MCU error trying to get UART between a pi3 and the fysetc Spider V2.2. Just stuck . I followed the github instructions using Putty. Have loaded the SD card I think correctly. I have triple checked the wiring and nothing is getting me working. Have the pi talking externally through both Putty (terminal) and mainsail. It's probably something simple I am not doing right adding UART lines to config files. But something either is beyond me or isn't documented correctly.

Not my first CNC machine. I can follow instructions. Been stumped before fighting with MACH3 and breakout boards and VFD's and always got through. This one has me baffled.


May I ask why UART? We generally strongly recommend going USB unless there's a specific, special requirement to go UART (you can still use that goofy cable the spider includes for power if appropriate, just...ignore the data pins and run a USB cable)

That aside, exactly what os did you install on the pi, and which github instructions are you referring to?
I installed Mainsail and klipper. Also had to find a config.txt through I think a Voron build instructions link. The Github was Fysetc...

On face of wiring diagram there are some UART config instructions. No luck with them. Did a bunch of general searching for UART and RPI.

The error I am getting is no comms with mcu. When first booted I had a bunch of config items I worked through successfully. That left me with this mcu UART issue.

I guess I'll grab a USB cable and try again. I guess I was blindly following Fysetc through the install and so UART seemed to be how I was being pointed. That maybe because the kit didn't come with a separate 5V power supply.

What do I need to look out for to get back to USB or should I just reflash and start over just in case I have done something to the mcu comms that I can't figure out how to unwind. Do I need to unpin some of the UART umbilical to keep just the 5v power supply or are the other pins just inop due to config?
just reflash the spider with a firmware that's set for usb, and then update your printer.cfg to use that. You do not need to unpin anything. there's nothing wrong with the copper being there, just none of the hardware is being told to use it, thus it will be ignored...

I'd also, in the more general sense, encourage you to pay a little more attention to the Voron instructions, and a little less to the Fysetc instructions. (admittedly, I may be a little biased, but...)
docs.vorondesign.com is the place to be...
OK, thanks a bunch. I did follow the Voron manual to the letter until I got to the print head board and the Spider V2.2 differences. That's where I got in trouble.

Easy to just reload.

Hello Again,

I started the software install over using docs.vorondesign.com as suggested with a fresh USB cable and the UART cable for power. This did better but seems to be halted at the last verification step flashing the Spider. Here's a screen grab of the instructions I am following:

After flashing I get this:

But then this returns nothing after removing jumper and repowering the system.:


Does this mean the flash looked like it happened and didn't or am I so much of a pi noob that I just am missing something? MainsailOS still reporting MCU connection error. 1688577914405.png1688578777135.png1688579055523.png
There are basically two possibilities there. Either something is still wrong with the firmware on the board, or you've bumped into the awkward Debian udev bug.

First thing to do is check if the board is showing up in `lsusb`. if it is, the you're looking at the Debian bug.
If it *doesn't*, then something probably still isn't quite right with the firmware, and I'd want to get a look at your `make menuconfig`
I'll collect a few more screen grabs tomorrow and try to work it out. I believe Lsusb was showing the DFU machine as that is where I got its address. I tried to make the make menuconfig look exactly like the instructions.

Thank you so much.
lsusb *while it's in dfu* is separate. I'm talking about when the board is (or should be) showing up as an actual klipper device, after flashing.
Thought possibly that I hadn't done the final make command that creates klipper.bin file but this time ran through again just to make sure

Still same results. Below are results again ls /dev/serial/by-id returned nothing...

lsusb not in dfu mode:
a surprising number of spiders seem to show up without the bootloader (no idea why).
Might be worth reloading the bootloader, following the instructions here, and seeing if that makes any difference
Hi, sorry if this had been answered - had you set up Pi to work with UART? You need to do some small changes on Pi side to enable Serial port there to be used for connectivity.
I used this guide