What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Voron trident Z stepper moves differently

Azertime

New member
Hi, I am building A self-sourced voron trident (400x400x500 build), with a BTT Octopus PRO v1.1.

Everything is going great for now, toolhead is doing what it's supposed to etc.
Only I am now configuring the 3 Z-Steppers and they are doing completely different things.

  1. front left is noisy and when buzzed only moves down
  2. Rear functions exactly as expected
  3. front right doesn't move at all
I followed the wiring guide correctly, and used the provided config file and I can't find a solution for this particular problem (I use TMC2209 drivers)

Here is Z-stepper config sample I currently have :

Code:
#####################################################################
#   Z Stepper Settings
#####################################################################

##  Z0 Stepper - Front Left
##  Connected to MOTOR_2_1
##  Endstop connected to DIAG_2
[stepper_z]
step_pin: PF11
dir_pin: PG3
enable_pin: !PG5
# Rotation Distance for TR8x8 = 8, TR8x4 = 4, TR8x2 = 2
rotation_distance: 8
microsteps: 32
endstop_pin: PG10
##  Z-position of nozzle (in mm) to z-endstop trigger point relative to print surface (Z0)
##  (+) value = endstop above Z0, (-) value = endstop below
##  Increasing position_endstop brings nozzle closer to the bed
##  After you run Z_ENDSTOP_CALIBRATE, position_endstop will be stored at the very end of your config
position_endstop: -0.5
## All builds use same Max Z
position_max: 500
position_min: -2.5
homing_speed: 8.0 # Leadscrews are slower than 2.4, 10 is a recommended max.
second_homing_speed: 3
homing_retract_dist: 3

##  Make sure to update below for your relevant driver (2208 or 2209)
[tmc2209 stepper_z]
uart_pin: PC6
interpolate: False
run_current: 0.6
sense_resistor: 0.110
stealthchop_threshold: 0

##  Z1 Stepper - Rear Center
##  Connected to MOTOR_3
[stepper_z1]
step_pin: PG4
dir_pin: PC1
## Octopus 1.0 & 1.1.  Octopus PRO 1.0
#enable_pin: !PA0
## Octopus PRO 1.1
enable_pin: !PA2
# Rotation Distance for TR8x8 = 8, TR8x4 = 4, TR8x2 = 2
rotation_distance: 8
microsteps: 32

##  Make sure to update below for your relevant driver (2208 or 2209)
[tmc2209 stepper_z1]
uart_pin: PC7
interpolate: False
run_current: 0.6
sense_resistor: 0.110
stealthchop_threshold: 0

##  Z2 Stepper - Front Right
##  Connected to MOTOR_4
[stepper_z2]
step_pin: PF9
dir_pin: PF10
enable_pin: !PG2
# Rotation Distance for TR8x8 = 8, TR8x4 = 4, TR8x2 = 2
rotation_distance: 8
microsteps: 32

##  Make sure to update below for your relevant driver (2208 or 2209)
[tmc2209 stepper_z2]
uart_pin: PF2
interpolate: False
run_current: 0.6
sense_resistor: 0.110
stealthchop_threshold: 0
 
I tried different things, the motor front right motor which doesn't move is still humming slightly. I wonder if it has something to do with the motors winding.
 
The first thing I'd check is the motor wiring. Then I'd check the pin assignments. Here's mine for my Octopus 1.1

Code:
#####################################################################
#   Z Stepper Settings
#####################################################################
# LDO-42STH40-1684L300E, Rated 1.68A
##  Z0 Stepper - Front Left
##  Connected to MOTOR_2
##  Endstop connected to DIAG_2
[stepper_z]
step_pin: PF11
dir_pin: !PG3
enable_pin: !PG5
# Rotation Distance for TR8x8 = 8, TR8x4 = 4, TR8x2 = 2
rotation_distance: 4   
microsteps: 32
#endstop_pin: PG10 # for inductinve/Klicky
endstop_pin: probe:z_virtual_endstop # for Tap
##  Z-position of nozzle (in mm) to z-endstop trigger point relative to print surface (Z0)
##  (+) value = endstop above Z0, (-) value = endstop below
##  Increasing position_endstop brings nozzle closer to the bed
##  After you run Z_ENDSTOP_CALIBRATE, position_endstop will be stored at the very end of your config
#### NOTE: This was commented out (Klicky?) already, needs to remain commented out for Tap
#position_endstop: 1.3      # good start after calibrating.
#position_endstop: -4       # goodModified to negtive for UnKlicky clearance
position_max: 220
position_min: -6.5 #-2.5          # limit for adjustment range. Mostly relevant during calibration
homing_speed: 8.0 # Leadscrews are slower than 2.4, 10 is a recommended max.
second_homing_speed: 3
homing_retract_dist: 3
[tmc2209 stepper_z]
uart_pin: PC6
interpolate: False
run_current: 0.6  #Amps spec = 1.68, * 0.707 = 1.1 max, TMC2209 max = 1.2
sense_resistor: 0.110
stealthchop_threshold: 0
##--------------------------------------------------------------------------------
##  Z1 Stepper - Rear Center
##  Connected to MOTOR_3
[stepper_z1]
step_pin: PG4
dir_pin: !PC1
enable_pin: !PA0
# Rotation Distance for TR8x8 = 8, TR8x4 = 4, TR8x2 = 2
rotation_distance: 4
microsteps: 32
[tmc2209 stepper_z1]
uart_pin: PC7
interpolate: False
run_current: 0.6  #Amps spec = 1.68, * 0.707 = 1.1 max, TMC2209 max = 1.2
sense_resistor: 0.110
stealthchop_threshold: 0
##--------------------------------------------------------------------------------
##  Z2 Stepper - Front Right
##  Connected to MOTOR_4
[stepper_z2]
step_pin: PF9
dir_pin: !PF10
enable_pin: !PG2
# Rotation Distance for TR8x8 = 8, TR8x4 = 4, TR8x2 = 2
rotation_distance: 4
microsteps: 32
[tmc2209 stepper_z2]
uart_pin: PF2
interpolate: False
run_current: 0.6  #Amps spec = 1.68, * 0.707 = 1.1 max, TMC2209 max = 1.2
sense_resistor: 0.110
stealthchop_threshold: 0
 
Thank you for your reply, I'll check that and have a look at your config, also I initially didn't mention this but I am going for a klicky probe on my setup. Don't know If this has an influence for my problem or not but I guess not.
 
fixed, it was my wiring some crimps had snapped

thank you anyway for your help, I am starting to test homing now XY is ok but for Z it prints "Move out of range: 207.000 405.000 10.000 [0.000]"

do you have any clue ?
 
Check your X and Y min and max. Is that 405 move actually within the defined range? Where is it trying to move to home Z in the safe_z_home section?
As an example, here's mine for my 250 Trident:
Code:
[safe_z_home]
#  XY Location of the Z Endstop Switch
#home_xy_position: 142,260
# Changed to middle of bed for Tap
home_xy_position: 125,125
speed:100
z_hop:10

Note that the original location for the spec switch was just off the back of the bed. For Tap it's the center.
 
Top