What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

ADXL345 Accelorometer suddenly not found......

I have been strugling with a weird situation the last day or so.

A week ago I ordered 4 ADXL345 accelorometers on amazon.
I mounted one of them while looking in the docs for klipper.

I mounted it all correct and got it all up working.
I did a full ressonance test and entered the values into my printer config.

Then yesterday I wanted to test the SHAPER_CALIBRATE command and that also worked fine..and it worked perfectly by using safe_config.

I then decided to draw a longer wire so I could keep the ADXL fixed on the toolhead.
After mounting a new ADXL to the new fixed wire I keep getting
"Invalid adxl345 id (got 0 vs e5)"

I have tried using the old wire + 3 other wires. Short and longer.
I have tested with 3 different copies of the same ADXL345 board.

I had some of the mainsail/klipper modules that updated after I made the first install, but I am not sure if they updated before or after it started being buggy.

Any ideas?