What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

connecting to RasPi


Now I'm guessing tha this has been discussed elsewhere so please let me know where I should go :)

I have finally finished the mechanical and electrical build of a 2.4. I turned on the power and no blue smoke or loud bangs so a fair start. :)

Next I tried to install mainsail on the RPi and this is where it is all going hideously wrong! I have not managed to get the RPi to connect to a browser window (as I believe it is supposed to do). In my frustration, I bought a second RPi 3 B+ which is connected to my monitor via a KVM switch so that I can try things without removing the Pi from the printer. I installed mainsail onto an SD card and expected a relatively simple connection to the printer: how wrong was I! :-(
After 3 long days (for those of you that remember the Cadbury's advert) I cannot get a webpage connection to mainsail. I can ping the Pi but it does not show on the network as a web page. I have tried using Kihua to put klipper and mainsail onto the Pi lite OS without any success. I have tried most of what I can find with Google, again, without success. I have no idea what to do next!

At the moment, I have a very expensive paperweight on my desk which I was rather hoping that I might use as a 3D printer so if anyone can ppoint me in the right direction I would be eternally grateful. Thanks
You might be better off starting with MainsailOS. It's a pre-built OS image that includes the base system, Mainsail, KlipperScreen, etc.

If you install by that method, then you can follow the Mainsail team's instructions from start to finish to get to a working system. 👍
Are you following the Voron docs for the install?

Do you know the IP address of the raspberry PI? Once you have mainsail installed you should be able to enter the IP address into your browser and access Mainsail.
I had the same thought as @NoGuru. Can you pull up Mainsail on the IP address? I have trouble with the .local address, so I just point my browser at the IP. Can you SSH in to the Pi?

If you follow the instructions here: https://github.com/dw-0/kiauh you should be able to get remote access to your Pi via SSH right away, then install the other components and be up & running quickly. Make sure to do the Advanced Options step so Wifi and SSH is active.
I used ifconfig to find the ip address of the Pi and under lo it is However there is no IP address given for wlan0. I can ping but the browser says can't reach this page
I tried to used ifconfig to assign an IP address to wlan0 which was, apparently accepted but ifconfig wlan0 immediately afterwards gives no IP address. I have a picture of the results of the ifconfig to see if it makes any sense to you?ifconfig.jpg
That is not the right IP. Can you access your router or DHCP server? It's more like a 192.168.X.X IP

Also that is not the entire screen shot. Maybe there is missing info?
It's not connected to your network. I think you will need to edit the config file on the PI. Put the PI SD card in a card reader, and look for a file called readme or Network_config_readme or something along those lines. And you will need to enter your network information and save it.
There are two files that look interesting. One is "readme" in "overlays" which is an extensionless file and had to be opened in Bitburry. Its contents are well beyond my understanding!! The other is "wifi readme" which I am going to read and see if it helps. They are both in the mainsailos that comes from the Raspberry Pi imager
Yeah its the wifi readme, you have to enter your Network SSID and password and save it and you "should" be able to connect. I forgot the new PI image requires you to do it this way.
Yes, it tells me how to set a wpa supplicant conf file. I had already doen that but I suspect that I did not the syntax right and, in particular, the new line characters. I'll try that one again using notepad++. Wish me luck!
The ip address of does not accept SSH. Putty tells me that connection is refused is the "loopback" address. EVERY computer has the same loopback address. So up course you can always ping from any computer because it would be pinging itself.

the address "" is very much like the English pronoun "I". It turns out everyone calls themselves "I" or "me". It is the loopback name.

For now ignore WiFi. Make sure the Pi is connected by Ethernet and then check your router to see what IP address the Pi has. But the =IP address can change, likely it will not but when computers boot they ask y=the router for an IP address, routers typically give the same IP, but not always.

Once t boots, ssh should work.

After that details vary which OS you installed
The is just the device talking to itself. A nerd t-shirt I once saw: "There's no place like" :LOL:
Getting wpa_supplicant set up should allow access. Like has been mentioned, you should be getting a 192.168.1.x IP address for most home network setups.
Just in case anyone else has the same problem, this is the way I finally connected the Pi wirelessly. For 5 days I tried everything that was suggested or that I could find on the internet without any success. An ethernet connection let me find the IP address of the Pi but even that did not allow a wireless connection. Bearin g in mind that my paper printers, my laptop and my PC all connect to my wireless network witout any issues, I did not suspect the network was the cause of this; but it was!
I set up a new SSID using exactly the same router and, suddenly, a wireless connection to the Pi was available and is working reliably. I have no idea why my original wireless network would not connect to the Pi (and to be honest, I don't care) but if anyone would like to speculate, I would be interested. The old wirelss network continues to work on all other devices throughout the house and will still not connect to the Pi!

I always thought that wireless was a bad idea; give me cables anytime!