What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Solved Debugging an homing error with conventional endstops

Printer Model
Voron 2.4
Extruder Type
Clockwork 2
Cooling Type
Hey guys,

thats my first question here, got this step from lurking to asking because my 2.4 baby (1 and 1/2 years old, usually working daily like a charm) got a problem I am not able to fix by myself:

1. When I home the printer, the x-axis homes perfectly including the "second hit" after retract.

2. The y axis moves a bit and stops, as if it hits the trigger midair - even when it is around the center of the printer - followed by the retract motion. In fifty percent of the cases, Klipper tells me "Endstop y still triggered after retract" and in the other 50%, the "invisible wall" will be hit a second time.

3. When the x/y homing works (with the invisible wall!), the printer is ready to home z, which usually crashes into the bed, because it is not even close to the z-endstop.

And now the clue: When testet manual with M119, the y-endstop works fine. Open/Triggered status is 100% correct when I push the endstop by hand.

I already replaced the endstop-button, just to be sure, but this changed nothing. The wires don't seem to have an issue, they measure fine.

Where could I go on with debugging? I am happy about every glimpse of an idea.

The board is a BTT Octo 1.1, the printer runs Klipper on a Raspberry Pi 4 and Octoprint - just in case any of this informations is helpful.
Last edited:
My guess would be there is a wiring error that give false detections. The problem with intermittent wire issues is that they are hard to find. Perhaps run a new set of wires (they don't need to be in the drag chain for a test).
You think it's possible, that there is a "broken" wire somewhere, that only loses contact while in motion? Since i only measured the cables without the gantry moving, this is completely possible. I will try a new set of wires and test the endstop again.
Thanks alot, it was in fact a bad crimp on a connector, that only disconnected now and then while moving. Easy to fix, now it works like a charm. Thanks for the input!
I'm having a similar problem, I just found out to be the connector (mine is Fysetc connecting to a XY D2F limit switch board). Part of the problem arises from the tight space between the back of the printer where the Y limit switch triggers, and the board cable output. The portion of the 3/4-wire cables coming out of the connector are bent nearly 90 degrees. They get squeezed against the back of the printer during the Y homing, precisely when the Y endstop is about to trigger. One of my 4-cable harness was severed after 340h of print. Luckily I only need 3 to run D2F switches, but it's not reliable as when I apply pressure over the connector with my finger it results in x , y or both switches triggering. Bummer, I might get rid of this board and make a better version of it.