What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

EBB SB2209 CAN V1.0 (RP2040) + Voron Tap = Will not trigger Z endstop


New member
I am having quite the difficult time troubleshooting why Klipper will no longer trigger the z endstop no matter what I try... Tried shorting gpio21 directly to gnd and no change within Klipper. Also tried connecting to gpio22 and gpio6 but nothing will get Klipper to trigger the z endstop. Tried a fresh install of Klipper from scratch, using up-to-date install then reloading config, no change. Tried swapping with brand new spare SB2209 (RP2040) and a spare new optical tap module, but still cannot get z endstop to show triggered within Klipper.

Tried triple checking wiring, crimps, connections, config files, and I'm at a loss...

From printer.cfg:
endstop_pin: probe:z_virtual_endstop

pin: EBBCan:gpio21
x_offset: 0
y_offset: 0
#z_offset: 0
speed: 10.0
samples: 3
samples_result: median
sample_retract_dist: 3.0
samples_tolerance: 0.006
samples_tolerance_retries: 3

{% set PROBE_TEMP = 150 %}
{% set MAX_TEMP = PROBE_TEMP + 5 %}
{% set ACTUAL_TEMP = printer.extruder.temperature %}
{% set TARGET_TEMP = printer.extruder.target %}

{ action_respond_info('Extruder temperature target of %.1fC is too high, lowering to %.1fC' % (TARGET_TEMP, PROBE_TEMP)) }
{% else %}
# Temperature target is already low enough, but nozzle may still be too hot.
{ action_respond_info('Extruder temperature %.1fC is still too high, waiting until below %.1fC' % (ACTUAL_TEMP, MAX_TEMP)) }
{% endif %}
{% endif %}


  • IMG_9462.jpg
    686.3 KB · Views: 34
  • IMG_9464.jpg
    131.8 KB · Views: 38
  • config&logs.zip
    456.3 KB · Views: 5
Did you manage to solve this? I seem to run into the exact same issue with my TAP and EBB RP2040. I've measured resistance over S and G and I would assume it's correct since it changes from 200 Ohm to 1k Ohm when triggered. However, I cannot read the state in Klipper for some reason.
I ended up working around the issue, getting 5V and Gnd from the EBB RP2040 and using one of the wires from my old drag chain, wrapped it around the CAN cable back to my Octopus v1.1 for the signal pin instead.
For both of you: the board doesn't have a hardware pullup on gpio21 - so you need to list it as "pin: ^EBBCan:gpio21" in the config
You can also move it to gpio22 (still need the pullup ^ setting) - on my board the gpio21 pin was borked
Thank you! I've re-crimped some shorter connections and now have tap fully connected to CANbus board again, only the CANbus cable and PTFE tube going out of toolhead. Looks much better now.