What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Solved SB2209 RP2040 communication error shutdown


New member
Printer Model
2.4 r2 350
Extruder Type
Cooling Type
Whats up guys Im new here and new to building printers, I just finished my 3rd printer build in 3 months......0.2r1, Micron+, and 2.4 r2 350. I have a strange issue on my Voron 2.4 r2 350 with the CAN set up, I have a Octopus 1.1, BTT pi, and SB2209 rp2040, CAN bus bridge to BTT pi, sb2209 to the Octopus with a RJ11, I have about 90 hours on it using ASA, I switched to PLA with the doors open, and exhaust fan on, I can not get more then 15-20 min print time without a MCU EBBcan (SB2209) lost communication and shut down, I tried 20 times to get a PLA print done but same issue, I switch back to ASA and I have now done 11 hours with no problem, switch back to PLA MCU shutdown first 15min....I was thinking maybe something with the part cooling fan being at 100% with PLA so I changed the fan but still same issue. I can only guess at this point that there is a problem on the board that the temp of printing ASA is covering up, BUT I have no issues when its cold during home/QGL/change filament...the printer can sit idle for hours without that issue. On the toolhead I have Galileo 2, Knomi 2, SB rgbw leds for the logo and 2 for the nozzle, a Bambu clone hotend, and 2 24v fans for part cooling/hotend. My CAN baud is 1,000,000, any help is welcome I have just about lost my mind at this point.......when I look at the Klippy log this is what I see for the event :

Stats 20897.1: gcodein=0 mcu: mcu_awake=0.049 mcu_task_avg=0.000006 mcu_task_stddev=0.000004 bytes_write=49781528 bytes_read=13426374 bytes_retransmit=477 bytes_invalid=0 send_seq=1023881 receive_seq=1023881 retransmit_seq=1023752 srtt=0.002 rttvar=0.001 rto=0.025 ready_bytes=30 upcoming_bytes=0 freq=180003608 EBBCan: mcu_awake=0.011 mcu_task_avg=0.000011 mcu_task_stddev=0.000021 bytes_write=16289715 bytes_read=5247678 bytes_retransmit=690 bytes_invalid=0 send_seq=349036 receive_seq=349033 retransmit_seq=349036 srtt=0.007 rttvar=0.003 rto=3.200 ready_bytes=297 upcoming_bytes=1607 freq=12000398 adj=12000128 CB1: mcu_awake=0.000 mcu_task_avg=0.000009 mcu_task_stddev=0.000013 bytes_write=127809 bytes_read=395554 bytes_retransmit=0 bytes_invalid=0 send_seq=21277 receive_seq=21277 retransmit_seq=0 srtt=0.000 rttvar=0.000 rto=0.025 ready_bytes=0 upcoming_bytes=0 freq=50000045 adj=49998977 sd_pos=380330 EBB_NTC: temp=43.8 heater_bed: target=65 temp=65.1 pwm=0.096 mcu_temp: temp=31.5 CB1: temp=45.5 Chamber: temp=28.7 sysload=0.20 cputime=2714.416 memavail=665044 print_time=20901.986 buffer_time=2.326 print_stall=1 extruder: target=220 temp=219.0 pwm=0.982
Timeout with MCU 'EBBCan' (eventtime=20898.137245)
Transition to shutdown state: Lost communication with MCU 'EBBCan'
Dumping gcode input 0 blocks
Are you printing faster with PLA then ASA? My thought is maybe the RJ11 is wobbling with faster printing speeds? Maybe try switching to a CAN hat like a U2C or or device like it.
Are you running an umbilical to your tool head?
If so, is it running through any kind of strain relief on the ends that connect to the chassis/body of the printer and the tool head?
When you move the tool head around by hand, does the umbilical move smoothly over it's entire length, or does it seem to flex mostly where it comes out of the fixed points at the ends?

If it's flexing at these locations but the rest of the umbilical is fairly motionless when moved, you likely have a broken/breaking wire.
I just got another sb2209 rp2040 delivered today so the plan is to replace the RJ11 first, my umbillical is strain reliefed and has no hard bents in it...I have tried flexing it, pulling it, wiggling it, you name it without replicating the issue, but if the RJ11 doesnt fix it I will replace the umbilical after that....then I guess the toolhead board is after that. Im using the same print profile for pla but the volumetric flowrate is lower then my asa since im trying to print pla-cf. I will report back with my findings......I hope to have this problem wrapped up tonight or tomorrow night, so little time for this right now.
Well I think I found the issue, I changed the RJ11 connector and same thing, I went to change the toolhead cable, looked at the board and decided to change the 120r jumper cap...I thought about it and when it happens my Knomi stays on so it must be a communication issue, not power loss so took a chance and lo and behold im 3 hours into a pla print right now, I hope that was it...I have never got past 20min with pla. Seems to good to be true......I doubt that extra 15-18C chamber temp could cause it to expand enuf to keep the circuit closed.🤷‍♂️🙏
Nice find!

I have an EBB36 on a non-Voron printer that does high speed stuff.
I shook the jumper cap for the 120Ohm resistor off the board. Took me a week of frustration to stop for a moment and look at the simple things.
I now have 27 hours of print time with PLA without any issues so I think its safe to say that the jumper cap for the 120r was the problem, thank you guys for your input.