What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Octopus 1.1 with F446 chip Z Motor's not all moving at the same time.


New member
Printer Model
Voron 2.4
Extruder Type
Clockwork 2
Cooling Type
Good day everyone,

I am close to being done with my first build and have one issue.
I have an Octopus 1.1 board with a F446 chip as my mcu and a SB2240 running can from a U2C
I can home X and Y ok if I set safe_z_home option z_hop to 0. If I set it to the standard 10, only stepper_z moves. z1,z2, and z3 do not move.
When I go to home Z, only stepper_z moves. z1,z2,z3 do not move.
I have tried both pre-compiled and compiled my own firmware.
Compile settings STM for F446 12mhz.
I can Buzz all 4 and they move fine. My setup is
Z1 Z2
Z Z3
Klipper versions
Version: v0.11.0-205-g5f0d252b

mcu EBBCan(stm32g0b1xx)
Version: v0.11.0-205-g5f0d252b

Host(aarch64, 32bit)
Version: v0.11.0-210-g0539e9f2
OS: Raspbian GNU/Linux 11 (bullseye)
Distro: MainsailOS 1.2.1 (bullseye)

Printer.cfg is attached.
Any help is appreciated.


  • printer.cfg.txt
    13.8 KB · Views: 8
You say buzzing them all return with a good response?
Do you have the wrong pully installed?
Yes, I did figure out what the problem was. I wired them straight using the ldo cables that came with the kit. It dawned on me that they cant all turn clockwise or anticlockwise at the same time 2 will need to go each way. If the left motor turns cw |-- --| the right would have to turn acw. Fixed the directions with !DIR and it all works now. Drove me nuts for a couple days. Thank you for the help. I am just waiting for my buildplate to come now to finish. I have the heat pad and magnetic spring steel sheet. Ive been waiting on the plate for over 2 weeks now.