What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

TMC Reports error


Well-known member
I keep getting a TMC error on the toolhead extruder stepper motor.

BTT Manta M5p
Canbus to: EBB36 v1.1 toolhead board. (two of them - it's a Double dragon IDEX machine.)

The steppers on the mainboard all function properly.

I issue a "G1 E10 F10" command to do a function and rotation check on the extruder steppers.

BOTH heads report the same error. I even plugged in a 3rd stepper motor and same error. Swapping steppers... same error.

Any hints as to where to look?

Suspicious that I get the same error on both toolheads.

I've verified that the config files have the correct pin numbers assigned. The fans and leds work on the toolheads and no other errors reported.

It will report the error even if the steppers aren't connected.


  • Screenshot 2024-04-02 083124.png
    Screenshot 2024-04-02 083124.png
    49.6 KB · Views: 3
Some more diagnostics.

I ohmed the stepper and the A1-A2 shows continuity as well as B1-B2 - but not between so those aren't fried.
So I swapped out the EBB36 with a spare one. Working now... but not sure if it was the board, the Katapult/Klipper install, or the LED chain. I left the LED chain off as it wasn't working. So perhaps that was shorted. Haven't plugged it in yet and won't until I get a chance to pull that out of the head to see what's wrong with it.

I tried to comment out the 2nd toolhead, but that get complicated with the hybrid Core-XY printer.cfg setup.
Last edited: