What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

error MCU 'mcu' shutdown: Timer too close

hoodlum

New member
Hello! After assembling and installing klipper and running homing, the Z axis starts to go down and immediately an error appears and stops. The USB wires have been replaced many times, the connectors too. The power is checked everywhere, but the error always occurs. Help me figure out what's wrong, where else to look?
 

Attachments

  • moonraker.log
    5.8 KB · Views: 3
  • klippy (4).log
    56.3 KB · Views: 5
  • photo_5215616188011366305_x.jpg
    photo_5215616188011366305_x.jpg
    16.3 KB · Views: 24
  • photo_5212986632939095611_y.jpg
    photo_5212986632939095611_y.jpg
    208.2 KB · Views: 22
  • photo_5211093372700314323_y.jpg
    photo_5211093372700314323_y.jpg
    220.1 KB · Views: 22
Last edited:
I don't have a solution to this, but I did some research just in case I'll encounter the "Timer too close" error in the future.
After reading a lot of posts in different places it seems like the TLDR is:
  • Avoid anything that could put a high load on the cpu, such as having a weak cpu and using a taxing webcam, or using elaborate LED effects while homing, probing or input shaping.
  • Avoid misconfiguration, such as calling missing macros or referencing non existing files. Apparently this can result in a high cpu load while searching for the missing files/configs.
  • Avoid thermo throttle, make sure the cpu doesn't run hot.
  • Make sure the klipper compile settings are correct, such as the clock frequency.

Some of the solutions to the "Timer too close" issue, found in various posts on reddit, github and such:
  • I was running a BTT Octopus v1 / 1.1 and this was caused by having the incorrect clock reference by default in the kiuah update script. Default is 8, correct is 12. This is noted in one of the octopus manuals but I missed it and a firmware update broke it.
  • Issue was that my slicer referenced start/end macros that did not exist in the klipper config.
  • I’ve also come across this problem using a pi3b+ I disconnected the webcam because I noticed it was being laggy. I haven’t had the problem since. Now I just use a Wyze cam for monitoring.
  • [This guy was running klipper in a virtual machine]: Hi, for me it was as easy as setting the usb to usb 3 on the vm. Have many hours of printing now with this rather weak laptop.
  • [This guy was running klipper on a Pi 1]: Just a shoot in the dark, but after I installed numpy to run input shaper on Pi 1, it got overloaded and it would not connect to the MCU anymore with "timer too close" errors. Just putting the same sd card into Rpi3 fixed that.
  • [This guy was running klipper on a Pi 2]: used the same code on a pi 3 and everything works. Weird.
 
Top