What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Galileo 2 & BTT SB2209 CAN board


New member
Printer Model
Voron 2.4
Extruder Type
Cooling Type

I'm upgrading my 2.4 to a BTT SB2209 tool board and am having issues with the LDO motor supplied with the Galileo 2. The motor works fine plugged into a motor port on the Octopus 1.1, but will not work on the SB2209 tool board. All other functions of the tool board are fine, just the extruder motor is not working.

Has anybody had this issue? I've tried swapping the wires in the connector, and ensured the pairs are matched with a meter, but it just won't run.
Do you have 24v at the SB2209? If its not that then do you have the pin config correct?
Hi NoGuru

Yes 24v is connected, and the hot end heats, fans run, probe and endstops work. In terms of the pins in the Klipper config, I replaced them with the ebbCan: pins as shown in the SB2209 manual for enable, step dir, diag etc along with the correct UART pin.

The manual only shows the motor connection in pairs (B2B1A1A2) which is how I have the plug wired currently. As I said, it works if I plug the motor into the Octopus 1.1 and change the pins back in Klipper to refer to that motor port, so the motor is fine.

I'm stumped!
Last edited:
Ok, I found the issue, I needed to invert the enable pin on the motor. I got thrown off because I was battling with a faulty driver on a previous board and was convinced I'd already tried it but it seems not. All working now, so thank you for pointing me back to pin configuration!
Just checking but did you heat up the hotend when you checked for extrusion? I think the default is set to like 150 before it will extrude.
I have mine set to 0.