What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Octopus 1.1 - bad board?


Printer Model
Voron 2.4 r2
Extruder Type
Clockwork 2
Cooling Type

Building Voron 2.4 300 kit from LDO motors. I am at the stage where I need to get Octopus 1.1 board working (with Klipper) and flashed, and now believe, after 2 days of testing, that I have a bad board.

- with only power supplied (no fans, thermistors, HE, etc attached, just driver chips), the power LED lights up (either external or USB-supplied), the board will "Not" appear as a USB serial device
- tried with external power and USB Power (with appropriate jumper in place)
- Tried flashing firmware with SD card (boot jumper removed),
- Tried in DFU mode with boot jumper in place

Tested with:
- 2 different RPI 4Bs, both of which can read serial USB on a different printer (Prusa Mini+, running Klipper).
- one Windows PC using STM Cube Program, which I verified can connect via USB to STM chip (on my Prusa)
- multiple different cables

So, regardless of power source, the USB port just does not appear (either as Serial device in RPI /dev or with USB-connected Windows PC with STM Cube program.

In all cases, power LEDS come on with the Octopus - either green when USB-powered, red when powered by 24V supply.

My conclusion is that USB-C port on the Octopus is bad.

I have sent email/trouble ticket with BigTreeTech, but no response (yet)

Any other suggestions?
Thanks for inputs. After failing to get the Octopus to enumerate on 2 different Kiauh setups on 2 different RPI (verified to work on usb-attached prusa running klipper), plus STM32 Cube program on. Windows PC, I worked with LDO (kit supplier) and they are sending me a replacement Octopus board. Hope to receive it in the next day or two, and then finish up the kit....
FWIW, the kind folks at LDO Motors sent me a replacement Octopus 1.1 board that booted just fine in DFU/USB mode and I was able to flash it with Klipper in less time than it took to write this post. So, onwards to finish my 2.4 build and start testing and tuning... ( previous board must have been faulty)...