What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Octopus Pro PB0 pin not working for Neopixels


New member
I am in the process of converting my old RAMPS V2 to the Octopus Pro with a stealthburner. I have connected my neopixels up to PB0 and they do not seem to work. Just to check I made a new string of 3 and connected it directly to the board. I have also tried this on PB6 with the same issue. I have confirmed that the neopixels are getting the 5VDC supply.

I took at look at the schematic and it seems that PB0 is connected through a buffer. Does that buffer convert the output from 3.3VDC to 5VDC for the neopixels?

Also to do a quick test I removed the stealthburner led config file and created a new pin in my printer config so that I could toggle it with the terminal. I test this on PB0 and did not see a change in state. I also tested it on PB7 and it showed 0V for low and 3.3VDC for high. I haven't had a chance to test it on PB6 yet. I have a bad feeling that this means my PB0 channel or buffer are shot.

Just to test I tried connecting the neopixels (WS2812B) to the PB7 port, but again they didn't light. I'm not sure if this is due to the signal voltage being 3.3VDC instead of 5VDC.

I'm just wondering if I should be able to toggle PB0 and PB6 as a standard pin for testing or if there may be a configuration for enabling those pins that I might be missing?

I'm using both ports and never had an issue with them. Here's my config definitions:
[neopixel caselight]
pin: PB6
chain_count: 36
color_order: GRB
initial_RED: 0.0
initial_GREEN: 0.0
initial_BLUE: 0.5

[neopixel sb_leds]
pin: PB0
#chain_count: 3
chain_count: 10
color_order: GRB, GRB, GRB, GRB, GRB, GRB, GRB, GRB, GRBW,  GRBW
initial_RED: 0.0
initial_GREEN: 0.0
initial_BLUE: 1.0
initial_WHITE: 0.0
The caselights are just two 18 LED WS2812B strips, the SB is spec NeoPixels at the nozzle and a Rainbow Barf in the logo.
Thanks for the quick reply and a copy of your config. You are doing exactly what I'm trying to do. I was able to set PB6 up yesterday as a pin and toggle it, so it works. I then switched it back to a neopixel pin and connected three neopixels up to it and it worked! So I can at least use that for my SB. Still can't seem to get PB0 to do anything though. I will probably just try to connect my case lights up to PB7 as that pin seems to be working when I toggle it.

Thanks again.