What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Stealthburner with Tap is looping on the homing/QGL before print

Not sure what is going on with this new Voron Tap + SB install.

I just installed Stealburner and in the same take I installed Tap.

Everything seems to work perfectly fine...UNTIL I want to do a print...

If I am preheating to 240C then when starting the print it is lowering the toolhead temp to 150C to be able to home and QGL.
When it is done with that it cancels the print with the message "Extrude below minimum temp" and "Extruder not hot enough".

if i instead starts the print job from a cold hotend state like 100C then it starts by heating up to 240C....THEN it cools down to 150C and going through the same erroring as mentioned before

I did the setup as told the both the SB setup instructions by copying the "stealthburner_leds.cfg" to the config folder..and that part works.
I also made the changes to the config file as mentioned in the "tap_klipper_instructions.md" from the Tap config folder.

how am I supposed to print?
You added this to the Probe section of the printer.cfg?

{% set PROBE_TEMP = 150 %}
{% set MAX_TEMP = PROBE_TEMP + 5 %}
{% set ACTUAL_TEMP = printer.extruder.temperature %}
{% set TARGET_TEMP = printer.extruder.target %}

{ action_respond_info('Extruder temperature target of %.1fC is too high, lowering to %.1fC' % (TARGET_TEMP, PROBE_TEMP)) }
{% else %}
# Temperature target is already low enough, but nozzle may still be too hot.
{ action_respond_info('Extruder temperature %.1fC is still too high, waiting until below %.1fC' % (ACTUAL_TEMP, MAX_TEMP)) }
{% endif %}
{% endif %}

Try a different slicer to see if it is a problem with your Start_Print in the slicer.
Do you have commands to bring the extruder back up to temp after QGL in your print_start?
@NoGuru Yes I added that.
@claudermilk is on the right path...I guess I have just been expecting there was a more complete standard setup for the tap same way as there was for the Voron 2.4.

I found some various cfg's out there that I could study and now I seem to be able to print. Right now I am trying with PLA but that needs glue to be able to stick.
I have tried for a couple of days with the new SB head to see if I could print ASA but no luck..I guess I have to add adhesion helper for that as well.. The gluestick I have just wont help there since it dry out fast.
I guess I said that too early..halfway into printing a test cube the print was dragged off the build plate...so not even with glue is it possible to print with this printer.
I have double checked my printers build several times...it seems to be well put together and all motors are tightened. Extrusions are angles correct.
As I explained in another thread when I first got it up running with the AB it printed perfectly fine for 5 prints...no brim, glue or warping..just nice prints...and then out of the blue it wont stick

Then the next day it WILL stick again..and it prints fine...but next day it wont....

I had a lot more success with my anycubic vyper.

Sorry but this is frustrating.

Edit..the printer is a Formbot Kit
Sorry to hear you are having so much trouble. I have occasional print issues but mine works great most of the time. Maybe go through this guide to see if any or all of it helps with your issues.
I reference it all the time. Even if I see an imperfection in my print I comb though it to see if I can tweak something to help.
Thank you very much.

I printed the 1st PLA with a bed temperature at 50C (The one that failed even when using glue).
Right after I replied here I started the exact same print just with a bed temperature at 60C and glue.
That one stayed on the buldplate and it didnt warp.

Then I made another again with 70C on the buildplate and NO glue...that one was sticking perfectly.

This PLA is from a role I have used not long ago on my other printer and have never been able to use it with hight buildplate temp than 50C.

So maybe my whole problem is about the buildplate after all...it seems like it only reports around 60C with another temperature tester on the plate after soaking 20-30 minutes but being set to 70C.
@Zephyrus67 , I haven't build my Voron yet, so take this with a grain of salt, but I have found reported hotend and bed temps to be more like an estimate. I routinely have to run my Ender 3 at 10-15 degrees hotter than what a filament requires to get decent results. I will probably invest in a cheap infrared thermometer to see what the temperature actually is (but then I will be relying on another piece of cheap electronic equipment . . . )
@bwingate Oh I am aware of that, but if the temps read by the heaters own thermistor is constanly 15-20 percent higher than TRUE temps then it will stop heating when my heater is reported as 110C while it might only be 95C and that can be a problem. With the 120C limit set it would prevent me from getting ASA and ABS printed. And I dont really want to go and change the limits in the configs.
Back to testing with ASA at bed temp 110C

After moving back to testing again with ASA I need to adjust my z_offset to be 0.1 lower than for PLA.
Is this normal? I thought the whole idea of the Voron Tap was to avoid things like this....
Back to testing with ASA at bed temp 110C

After moving back to testing again with ASA I need to adjust my z_offset to be 0.1 lower than for PLA.
Is this normal? I thought the whole idea of the Voron Tap was to avoid things like this....
Different types of filament require different tuning. AS far as Z height, anytime you change types of filaments you should always do a PROBE_CALIBRATE.
I do a PROBE_CALIBRATE every 5 to 10 prints anyway to compensate for climate variables.
Then I made another again with 70C on the buildplate and NO glue...that one was sticking perfectly.

I have the same experience.
PLA sticks quite well to the bed at 70C but not so much below that.

My 2.4 printer is also built from a formbot kit, it came with a single sided PEI covered metal sheet.

The bed temp reading is accurate to within a couple of degrees. I have measured actual temps with a thermocouple, as well as with the "MacGyver method", see

So I can say with absolute confidence: With my PEI sheet the actual bed temp must be at least 65C to get PLA to stick well. I use 70C when I print.

Edit: I should mention that I also tried first layer squish and extreme elephant foot. :) Nope, didn't do the trick. Higher bed temp was the answer.
Last edited:
I have been ongoing with testing this and that but still without being able to make a successful print with ASA (even though I was able to do 5 prints with ASA right when I started the printer up at first).

I did the Ellis Tuning thing but that made everything worse. My gantry that was perfecly well before was suddenly skewed so I did it all again and got it back as it was from start. It was aligned well from start so I should have known not to go that way...

Nothing helped from that though....Now I must up close to 120C on the bed to get adhesion. And then the printer shuts down (at least that part works)

I have since the beginning had a weird medium loud sound from the z axis when it was moving (up and down). I have basically just thought of that as resonance in the acrylic sides/back etc.
But since I dont really get anything out of this printer as it is (I have more successful printing exeriences on my Vyper) then I decided to go further and see if there was any noise from the motors when not attached to the z drives.

So I dismounted all 4 z moters and let them keep the connectors in them. When I was activating only the Z motors I heard that some of them made more noise than others..and some of them a lot

I found that one of them were a lot more noisy than the other. To check if that was because of a defect in the motor itself I swapped it with the most silent of the z moters...now the noisy one was suddenly the silent one...

I take that as the noise is due to bad stepper drivers (or bad potentiometer settings on the stepper drivers.

But the question is...can this also be the reason for first layer issues I have?
Sounds like maybe a stepper issue.

When I got some new build plates a while back I had fits trying to get anything to stick to them. Sounds a bit like what you are struggling with. Ultimately I got some 600 grit sandpaper and *lightly* sanded the PEI. Then I went through the dish soap & scrubby pad then IPA cleaning. They have worked well since then.
@claudermilk Did you have a stepper issue as well or did I read that wrong?

Yes I have also already tried all kind of cleaning the printer surface dish soap, IPA and even a bit of acetone to see if that would degrease the surface.
I have not been sanding the PEI sheet yet since I assume that can potentially also ruin the surface.

Which side of the PEI sheet did you sand?
Today I cleaned the surface with a mix of IPA and acetone and managed to get some 20x20 test cubes printed with good adhesion. Settings were 240/110

Then I did a new attempt on making a new front for my stealthburner since the one that is on now is printed on my Vyper..and even though it prints and finishes the job everytime then the print is not so pretty.

after 41 layers with 240/110 the print warped like shoesoles but I have come to a point where that is what I expect.

I am now on a new attempt on same front for the SB but now squished a little closer to the PEI and with 255/115

I might be able to print things like this with 120/125 bed temps..who knows...but then the thermo fuse will kick in.
No stepper issue here.
I was really reluctant to sand the surface for the same reason. After all other attempts failed--including acetone--I finally resorted to sanding. I used a block of wood with the sandpaper wrapped around it and very light pressure. The surface is now matte and scuffed evenly--and prints stick. It was scary, but it worked. This is for the smooth side--textured has not given me the same issues when I use it.
I would not even start working with the smooth side having issues with the textured side :)

Anyway...I have been done more testing....I managed to get the front for my stealthburner printed.
It took 255C nozzle temp and 115C With the ASA I usually print from 235C and 100/105C on my vyper...that part is strange for me..

I also had to squish the nozzle closer to the surface. This resulted in a very tiny and no treally visible elephant foot..it was something I could feel though with my fingers.
For this to work it seems like I need to clean the PEI sheet first with IPA mixed with a bit of acetone. If I dont do that (the acetone is a MUST) then I get warps.

I think I have come to the conclusion that all this IS about the print surface. I might just have gotten a very poor copy of the PEI sheets they stock with the printers from Formbot..

I have purchased something called dimafix that I have been told is good for adhesion. If this is working then I will be fine. IT would be fine of corse not needing any adhesion helper at all.

Now I am trying to find out if a nozzle scrubber will work with Voron Tap...I am getting a little tired of the oozings disturbing the first layers...
Strange, my Formbot PEI worked great for me.

Nozzle scrubber and TAP do work together.
Yes but I guess PEI sheets can also come in monday/friday copies :)

And yes scrubber works with tap. I Installed the decontaminator scrubber last night and it works. I rewrote the macro though. It seems like the macro he made forces 240C for it to be able to purge.

I also still have left to find out why my steppers are so noisy. Especially the Z motors sounds like I am drilling into concrete with a drill hammer.
Might want to disconnect Each Z and test one at a time. They should not really be loud.