What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

TMC Extruder Error


Well-known member
I'm posting my inquire here since I am building my 2.4 with a Stealthburner + CW2 and using a LDO Neam 14 36mm (LDO 36STH20-1004AHG) as the extruder steeper. I also use a 2-piece Hartk SB PCB.

My 2.4 350mm build is almost finished. I am running through the 'Initial Startup Checks". All was going well until I tried to extrude some filament, PLA. I set the hotend temp to 190C and tried to extruded some filament when I got the following error:

TMC 'extruder' reports error: DRV_STATUS: 000f00e0 s2vsb=1(ShortToSupply_B!) ola=1(OpenLoad_A!) olb=1(OpenLoad_B!) cs_actual=15

Since I built my own wiring harness instead of ordering off-the-shelf, I figured there was most likely a wiring issue. So I rechecked the steeper motor wiring from the toolhead (I have a 2-piece Hartk SB PCB) to the mcu (Octopus V1.1) but found no issue. I had continuity from the PCB to the mcu. I also double checked the E0 plug at the mcu to ensure I had not crossed the wires from the PCB but that looked good as well.

I issued a 'DUMP_TMC STEPPER=extruder' command form the console and noticed that DRV_STATUS was "DRV_STATUS: 800f0040 ola=1(OpenLoad_A!) cs_actual=15 stst=1"...

From what I can tell from the "TMC2209 Datasheet" s2vsb=1(ShortToSupply_B!) indicates low side short phase B and ola/olb indicates a open load phase A/B but that could be a false detection. I pulled the driver from the board to check connection but that seems good.

At the moment I'm scratching my head to figure out this problem. I believe my wiring harness is good, the driver is good, the motor is good.

Forgot the mention that I plugged a spare Nema 17 I had into the E0 socket on the Octopus and it worked when I issued extrude command from the Klipper Dashboard.

Any Suggestions??

Last edited:
I tried a experiment with a Nema 17 43mm pancake. When plugged directly to the Octopus board it worked fine. So I made an adapter so I could plug it in to the smaller JST socket on the SB PCB. It worked but not well. When I issued a extrude command, instead of the shaft slowly turning it dithered back and forth. I then made an adapter for the Nema 14 36mm stepper (since the PCB used the small JST connectors that won't fit the JST socket on the Octopus) and plugged it directly to the Octopus board. I did not get an error, as I did when connected to the PCB, when I issued the extrude command but instead the shaft dithered about like the Nema 17 did when plugged into the PCB. The results is confusing to me. I expected the Nema 17 to either work or not work when plugged in to the PCB socket not sort of work. I expected the Nema 14 to work when plugged to the Octopus not sort of work. The Nema 17 dithering when connected to the PCB makes me think the connection lines are mixed or bridged. But I don't see how that could be the case for the Nema 14 when plugged to the Octopus...arghhhhh @#$%^&*(....
In my experience with steppers not working or working poorly, a flat out short will give you the open load error, and a poor connection will cause the stepper to jitter back and forth (as you're seeing with your adapter). Since there is no actual standard regarding stepper wiring order, steppers from different manufacturers could be wired differently, and each PCB they are plugged into could have a different pin order.

You'll probably need to grab a multimeter and check the wiring order of the stepper you want to use, then match it to the schematic of your PCB's pinout. Since you have some jitter to one of them when connected to the toolhead PCB, I'd say the wiring order is correct, you just have a bad connection (bad crimp, bad wire, etc.).
son of a motherless goat...two problems...first, as I suspected because of the dither with the Nema 17 plugged into the PCB socket, my steeper wiring harness had two lines crossed at the Octopus plug. Damn I tripled check with a multimeter and still screwed it up...argghhh...Second, as suggested by ah2049 above I had a bad crimp with the JST-PH plug on the Nema 14...again damn because I called myself double checking the crimps before installing each line into the JST plug...well as I have said before... once you have suffered enough, things work...

thanks for the input