What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Various help with Config

Locky83

Member
Printer Model
Voron 2.4 350mm
Extruder Type
Clockwork 2
Cooling Type
Stealthburner
Hi All,
Complete Noob here just trying to help my son get his Voron 2.4 350mm build up and running.
I am following this video by Scott Corn
In addition to this, I am following this video by Nero 3D for the changes to suit TAP:
I've made all the relevant changes in both of these videos and I thought I have done everything right, but I have an error when I press Save and Restart

Klipper reports: ERROR

Unable to parse option 'stealthchop_threshold' in section 'tmc2209 stepper_z3'

Once the underlying issue is corrected, use the "RESTART"
command to reload the config and restart the host software.
Printer is halted

Ï can't seem to find any information about how to fix this error.
Printer Config File attached.
Any help at all would be greatly appreciated. I have no idea what I'm doing.
 

Attachments

  • Config as of 26.12.23 with error.txt
    18.2 KB · Views: 7
You've got an error on line 235 of the config.
Code:
Heater - HE0
is just user information, not part of the config, so it should be
Code:
# Heater - HE0
 
wow that fixed it, I would have never worked that out on my own as the error never pointed me there. thank you so much!
 
It did...kinda. what was happening was in two parts

1. It was the very next non-comment line after the one the error seemed to point to

2. It was indented.

The combination of those two things meant that, as far as klipper was concerned, the line I flagged was the continuation of the line klipper flagged
 
Thanks again for that help, just got back from a family Summer holiday so I'm back at it now.
I have been struggling all day trying to figure out 2 issues before asking for more help but it's time to give up.

When I "STEPPER_BUZZ STEPPER=stepper_z1" This stepper motor is not responding, all other Z's, and the X and Y are OK.
I have swapped the plug around for motors Z1 and Z2 and this motor works when it thinks it's Z2, so the issue must be in the config. Problem is I can seem to find what is wrong?
Printer config attached.

Second Issue is the thermistor thinks that it is 169.9 degrees straight away, although in reality it is room temp. I have this thermistor:

Thanks in advance from struggle street.
 

Attachments

  • 20240104.txt
    18.2 KB · Views: 1
I figured them both out! I just had to walk away from it and come back a day later to see the forest through the trees.
Z1 Stepper was not working as I had Enable Pin commented out.
I changed the thermistor from Generic 3950 to PT1000 and that solved that problem.
 
A bit of advice after building 2 Vorons (a 2/4 and a switchwire conversion) - you will need to be very patient with walking through the printer.cfg files. The good thing is that the log is verbose, but it's pretty clear where the error is in the log if you clear the log, re-do the error, then word search for "error".

The status notes you have already seen may be a bit esoteric at times, but the generally point to the issue.

As you walk through the startup, the Print_Start will be the next headache! Also disconnect the bed heater power and the hot end power until you are ready to test those.
 
Top