What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Canbus help


Could really use some help on this one as I have run out of ideas. 6 weeks ago I performed a update which cause the UUIDs to stop working. There was a patch released to resolve this but unfortunately didn't work so had to reinstall software. After a successful software install which I had to use the patch, I am now getting the above problem. I have installed a new cat6 shielded cable and a new high-end USB type c as well as trying others. As far as I can tell, everything is stable until I try to hate up the hot end then after about 5 to 15 seconds I get the above issue. I have tried disconnecting, hot end and same results. The machine was running perfectly before the software update. Any help would be appreciated.


  • PXL_20230620_082815794.jpg
    572.7 KB · Views: 23
Hmmm, I don't know the answer, nudging around to see if anyone has more ideas. I've seen a few people say they resolved it by moving to a more capable RPI.
A user on the discord reports that their problem went away after they
Switched to 1M canbus speed
Reflashed the octopus.
Reflashed the EBB without canboot
Funny. I can't get mine to run with canboot neither. My speeds are set to 1M And have tried reflashing the octopus. Got a feeling it's software related and has something to do with this patch. Maybe I will try using mainsail instead of fluid.
Could you post your klipper config? A common cause of this is that people have stupidly high microsteps in their config.
I had that issue too, it is a problem with the latest versions of one of klipper's dependencies. You can fix it by downgrading:
cd ~/klippy-env
bin/pip install aenum==3.1.12
and then restart the klipper service.
Looks like that package was just updated, the latest version works for me now. So ignore the above instructions and upgrade it instead:
cd ~/klippy-env
bin/pip install -U aenum