What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Solved Changed from Fly SB2040 to BTT SB2240 - MCU: Can not update MCU 'mcu' config


Well-known member
I switched from the Fly SB2040 to the BTT SB2240. So far ok - after endless hours - but now this error message appears and I don't know whats wrong.
If I detach the Beacon probe, the error message appears that it has not found it (that is correct). When I disconnect the thermistor from the hotend, the message "ADC out of range" also appears correctly. So basically it's not that wrong...
But when I attach everything, this message appears from the MCU. I updated the mcu (Octopus v1.1) via CanBoot to the same version as the EBB, did not help.
What is wrong?? What information do you / I need for troubleshooting?
Hey Yez, that sucks. I will help you trouble shoot this. I am a little confused by your post.

Was the new CAN board ever working?
Is there any jumpers required for the board to work, or Diode?
Is the baud rate speed the same on all the boards?
Have you tried other baud rates?

I am not sure why you mentioned Beacon. That should have zero impact on the CAN board.
Thank you very much, I could find the problem now: I had a break/loose contact in the CAN plug. I could flash the EBB and everything but then had some weird behaviour. I crimped a new cable and it is working now :)

I mentioned the Beacon probe because it is connected with USB and so on another "level" than for example the thermistor which is connected on the EBB.
Glad you found it! CAN boards sorta suck so it can be a real pain to find issues.