What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Tap always registering as open


Hello, I'm upgrading my 2.4 to tap and the z-endstop isn't being recognized in klipper. The light on the PCB board stays red even when it should trigger. If I swap the signal and ground from what they should be, the light will toggle when trigger, but klipper doesn't register it when using query_endstops.

A couple questions:

I'm using the same wiring as the inductive probe. Should I remove the diode that I had in there for that?

What port should I be plugging the signal wire into? I'm currently using an Octopus board and have the signal wire in PB7 with that set as the probe pin in my printer.cfg.

The kit came with a resistor inline on the positive wire. Do I need this? It's not mentioned in any documentation I can find.

I have always had trouble with wiring the probe to PB7 on my Octopus. When I recently redid my printer wiring and added the new V2.4.1 Tap & 2-piece hartk I tried rewiring to PB7--no trigger even though the Tap board showed it registering. I moved the signal wire back to PG15 (STOP_7) and it immediately was recognized correctly. Note that the hartk PCB has a BAT85 integrated--it doesn't interfere for me at all.
The resistor is there to prevent an inrush current. It was a bug that was discovered in the first boards. So unless you want to buy a new board, keep the resistor.

If you keep polarity, the diode shouldn't matter.

To check if the board works as it should, there is a diode, on the board that should trigger when TAP is lifted. If that works, check your cfg it could be the wrong probe pin, it could be that you have to change the input behaviour. Test according to doc, if triggered is "open" and open is "triggered" put in an !...
good luck!
I just got mine working today. It was the biggest PITA of the entire build experience. I almost switched to klicky, in fact I was in the middle of switching when I decided to plug the tap in off the printer. I had loosened the pcb a little and viola! I started getting blue to red when lifting it (virtually, in my hands). After putting it all back together for the umpteenth time, I was getting it to finally show open and triggered at the correct time when lifted, however, like you it was not registering as hitting the end-stop so it wanted to crash the hot-end. After changing the PIN under z steppers to... endstop_pin: probe:z_virtual_endstop and then adding the gcode stuff under the probe section it worked. I used PG15 @24v. I am using a 2 piece cloned Chinese PCB. There was some pin rearranging that went on, but I used a multimeter to be sure I was getting ground to ground, signal to signal etc from the probe PCB all the way to the pin on the Octopus.

Have not tried my first print yet, but so far probe_accuracy burn in and multiple homings running in the 150-200 range and still working. Good luck
I see more people using PG15, but where do you get 24V from ? Is it from the J40 original sensor output ?
Yep, I have 24V and ground from the original probe port, and the signal to PG15.