What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Voron Tap config- extruder stuck at 150 and will not increase

jasonheck

New member
Just built a new 2.4 and added Tap, but the extruder will not go back to the standard temp for printing, after lowering itself to 150 to use the probe.
It keeps giving the "extruder temp to low" after the probe movement is finished, and stops. I am using Cura with the default 2.4 profile.
I added the config from https://github.com/VoronDesign/Voron-Tap/blob/main/config/tap_klipper_instructions.md to the probe section.
But I assume something in "print_start" needs to also be configured? Ive changed the print_start at least 10 times after some research, but results are the same.

Any help appreciated
 
Make sure this gets re-copied into your [Probe] section,


activate_gcode:
{% set PROBE_TEMP = 150 %}
{% set MAX_TEMP = PROBE_TEMP + 5 %}
{% set ACTUAL_TEMP = printer.extruder.temperature %}
{% set TARGET_TEMP = printer.extruder.target %}

{% if TARGET_TEMP > PROBE_TEMP %}
{ action_respond_info('Extruder temperature target of %.1fC is too high, lowering to %.1fC' % (TARGET_TEMP, PROBE_TEMP)) }
M109 S{ PROBE_TEMP }
{% else %}
# Temperature target is already low enough, but nozzle may still be too hot.
{% if ACTUAL_TEMP > MAX_TEMP %}
{ action_respond_info('Extruder temperature %.1fC is still too high, waiting until below %.1fC' % (ACTUAL_TEMP, MAX_TEMP)) }
TEMPERATURE_WAIT SENSOR=extruder MAXIMUM={ MAX_TEMP }
{% endif %}
{% endif %}
 
This is what I do to make sure the print temp is set before the print starts.

And also to go directly to 150C instead of first going to print temp, then down to 150.
But that's optional, to first go to print temp just replace "M109 S150" with "M109 S{temp_hotend}" in the PRINT_START example below.

PRINT_START is called from Cura "Start G-code" like this:
Code:
PRINT_START  BED={material_bed_temperature_layer_0}  HOTEND={material_print_temperature_layer_0}

This is done in the PRINT_START macro
  1. Read the temp values provided by the slicer
  2. Set bed to the temp value provided by the slicer, and wait
  3. Set hotend to 150C, and wait
  4. Do the usual stuff such as home, gantry level, probe and whatnot
  5. Set hotend to the temp value provided by the slicer, and wait


My PRINT_START looks like this:
Code:
[gcode_macro PRINT_START]
gcode:
  #--------------------------------------------------------------------------------------------------------
  #--- read values provided by slicer
  {% set temp_bed     = params.BED|int %}     #*** Required. BED value must be provided by slicer
  {% set temp_hotend  = params.HOTEND|int %}  #*** Required. HOTEND value must be provided by slicer
  #
  #--------------------------------------------------------------------------------------------------------
  #--- do the usual stuff
  M190 S{temp_bed}                            #*** Set bed temp and wait
  M109 S150                                   #*** Heat nozzle to 150 and wait
  G32                                         #*** Home all, probe bed, level the gantry and such
  G90                                         #*** Absolute positioning - don't remove
  BED_MESH_PROFILE LOAD=default               #*** Load mesh
  #--------------------------------------------------------------------------------------------------------
  #--- set hotend to the temp provided by the slicer
  M109 S{temp_hotend}                         #*** Set extruder temp and wait
 
I'm having the same issue that after probing it's stuck at 150 and won't go up again.
I'm using Orcaslicer
I also followed the instructions but can't get it to print

I have the "Basic" start macro:

[gcode_macro PRINT_START]
# Use PRINT_START for the slicer starting script - please customise for your slicer of choice
gcode:
G32 ; home all axes
G90 ; absolute positioning
G1 Z20 F3000 ; move nozzle away from bed


Any help appreciated
 
Last edited:
Just built a new 2.4 and added Tap, but the extruder will not go back to the standard temp for printing, after lowering itself to 150 to use the probe.
It keeps giving the "extruder temp to low" after the probe movement is finished, and stops. I am using Cura with the default 2.4 profile.
I added the config from https://github.com/VoronDesign/Voron-Tap/blob/main/config/tap_klipper_instructions.md to the probe section.
But I assume something in "print_start" needs to also be configured? Ive changed the print_start at least 10 times after some research, but results are the same.

Any help appreciated
In Orca Slicer, make sure you go into the machine g-code settings tab and copy the print start string for the slicer. I noticed pretty much the same issue before I did that, it would heat to 150, probe, then shut down instead of heating up to print.

M104 S0 ; Stops OrcaSlicer from sending temp waits separately
M140 S0
print_start EXTRUDER=[first_layer_temperature] BED=[first_layer_bed_temperature] CHAMBER=[chamber_temperature]

That fixed it for me. In Orca, click the "Edit" button right next to the selected printer and go to the Machine G Code and past that in the start. I have that in for my 2.4 and my new Trident, hope that helps, good luck.

** Also, add the following to your printer.cfg if using Orca, it fixes the thumbnails from not showing up on your Screen / in Mainsail**

# Enable object exclusion
[exclude_object]

# Enable arcs support
[gcode_arcs]
resolution: 0.1


Take it easy.
 

Attachments

  • 2023-07-03 (1).png
    2023-07-03 (1).png
    196 KB · Views: 64
Last edited:
Top