What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Voron V2.4 massive layer shift problems


Printer Model
Voron V2.4
Extruder Type
Clockwork 2
Cooling Type
Hey all,

Since some time i got massive layer shift issues and now I'm at an point where i dont know what I should do.
Layershifts happen at different layer heights.
Sometimes the print finish without problem.

What I tried already:

1. Checked the mechanic, put off the belts and checked the linear rails (relubed them)
2. Checked the belts if they are running correct
3. Checked the belt tension
4. Swapped my 0,9° No Name Steppers to LDO SuperPower LDO-42STH48-2804AC 1,8°
5. Checked Current and other settings like acceleration and max. speed
Current Settings:
- run_current: 1.6 A
- max. Acceleration: 3000 mm/s²
- max. velocity: 350 mm/s
6. Grub screws checked and tightened while exchanging to new steppers

The TMC2008 are actively cooled and are not getting warm.
The stepper itself gets to normal temperatures.

Hope someone maybe has another idea which can help me.

Best regards
Last edited:
The only thing that screams at me is the run current. You should be able to hit those speeds and accelerations easily around 1 amp. Running them that hot even with cooling. Is a little spicy.
The only thing that screams at me is the run current. You should be able to hit those speeds and accelerations easily around 1 amp. Running them that hot even with cooling. Is a little spicy.
i tried also at 0.8A and 1.0A but with the same problem. so to an advise of someone I made it higher. The motors should not have any problem, they also do not get hot.
They are rated at 2.4A.

But to be honest, I dont know where I should look next... I will check the routing of the belts again, but I already did it and the printer already was running without problems
When i had this it was due to the high infill width which many people use.
I think the default on ellis's profile is 180%, which is great as it reduces the total print time by doing more infill per pass. however it depends on the nozzle you are using. I had swapped to a tungsten carbide nozzle as i wanted to use some abrasive filaments.
The flat end of the TC nozzle is a smaller diameter than the line width when it is set at 180%. so it causes the extrusion to have a sort of valley and peaks pushing up each side of it. this can then cause enough drag to move the print. causing layer shifts. sometimes it detaches altogether but for example i had layer shifts on the Voron cube during my testing which is obviously quite a small print.

TLDR change the infill width to 140% and retry.

change your run current to around 1A. as Dustin mentioned, you may need to raise it if you want to push very fast speeds later on.

one other thing might be the belts misaligned in some way. Check that the belts dont show any signs of wear. if they do make sure the pulleys are aligned vertically correctly. a very slight misalignment can cause them to ride of up on the pulley edge or the bearings and cause all sort of problems.
i made a test with the test speed macro.

adjusted the current to 1.1A, Acceleration to 8000 and speed to 600
already got problems at QGL...
Checked the TEST SPEED with 5000mm/s² and 50mm/s
It moves good.
But when I touch the toolhead the motor skips and does really have not much power.

Also checked the belts and the routing of them is correct. Not the wrong routing as described everywhere. Also lifted the back panel to be sure the belts are not rubbing.

Also want to show you the qgl which worked and afterwards the test speed, where the error happens.
500mm/s and 5000mm/s²
Take the motors out and move the belts by hand and see if there is resistance. If there is then you would need to see if you can find it. You would be shocked at how Little it takes to cause an issue. When you make moves at high acceleration it can take very very little to cause a shift.