What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

EBB SB2209 X/Y Axis locations

Hi Folks,
New here :) Just finishing up my build with the M8P + CB1 + EBB SB2209 CAN
The X axis micro-switch can be moved on to the stealthburner rear gantry mount, but I don't see an option for the Y-axis micro-switch.
So.....if there isnt a Y-axis micro-switch new location, does it make sense to break down the X/Y microswitch PCB?

Anyone out there figured out a solution to this?

Thanks :)
Thanks for sharing! I saw that on a YouTube vid, wasn’t sure why it wasn’t included in the BTT GitHub repo.

Sensorless homing is on my list of things to do once it’s up and running. Not tried that before


Well-known member
Thanks for sharing! I saw that on a YouTube vid, wasn’t sure why it wasn’t included in the BTT GitHub repo.

Sensorless homing is on my list of things to do once it’s up and running. Not tried that before
It's incredibly easy to setup sensorless. I would say go for it first and if you have issue, add the switches later. It's in the Voron Document setup.
NICE - got lots more playing to do :) the EBB CAN setup is nice - just trying to figure out where I want the umbilical to go to and if I want any cables coming up the dragchains other than for the steppers.
ok so couple of things I discovered:
1. The jumper on 5V if powering from USB (which seems the only way to flash the SB2209 successfully the first time at least)
2. Hold Boot & hit RST does NOT enter the device into DFU - however unplugging the USB and replugging it WHILST holding BOOT does. This allowed me to flash the SB2209 from my laptop vis STM32 Controller software to load CANBoot. But now STM32 software claims the device is not recognized.
the instructions on this little board are somewhat lacking :( any tips/ideas?


Well-known member
For CAN bus there are so many different combinations, that I think the best place to ask is in the Voron CAN bus discord.

I think that is common for STM to not see it after the flash but don't take my word for it. See if you can get a UUID from the board.


Active member
Just curious @ah2049 - did you have to flash the mainboard with the new CANbus enabled firmware bin file (instead of USB) OR just the EBB SB2209?
I apologize for the super late response, I managed to miss this somehow.

For my setup (Octopus, Pi 3/4, EBB36, Waveshare CAN hat), I did not have to flash anything to the Octopus when switching to CAN. With that said, my CAN toolhead board is connected to the Pi via the CAN hat on the Pi, not to the Octopus itself. I used this video by @eddie to get mine set up with CANBOOT.

I did a little looking around, and it seems that BTT has this video here to help with CAN and the USB U2C board setup. It's about the EBB42, but it may be helpful in some way for the SB2209 if they didn't change how the boards operate (I assume there shouldn't be with both being STM32).
coming back here to post some progress (and thanks for the tips folks)
the pin out for the boards are as follows:

M8P: USB to CAN using (PD12/PD13)
SB2209: CANBus (PB0/PB1)

Can0 is UP, but getting a fairly generic serialhdl.py timeout error.
currently yet to see the UUID of the SB2209


Active member
Two thoughts:

1. After a quick google search, the timeout issue may be related to updates on klipper. Which reminded me of times when I updated klipper, it would break connection until I reflashed the toolhead board using the updated klipper. I haven't run into this issue recently, but it is a possibility you may be having this issue

2. Which Manta board version do you have? While looking through the BTT github, I noticed the v1.0 version has a PT1000 setup with no apparent CAN input, whereas the v1.1 has CAN in place of the PT1000. I'd like to hope you have the right board, but it will help to make sure you do before continuing to chase a issue you can't actually fix with a v1.0 board.

One more thing, make sure you have your CAN High and CAN Low wired correctly.
thanks for the reply, Yep i'm on 1.1 M8P which has the CAN input ports (PD12/13)
The CAN Cable is pre-wired (and based on pin outs looks right).

If using CanBoot do I need to flash both Main board and toolhead with CanBoot?
ok it was the 120R resistor jumper that was needed on the mainboard and the toolhead
made a PR request for the M8P but firmware info here:

and SB2209 here: