What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

Question Stealthburner neopixel LEDs not responding properly, what am I doing wrong?


New member
Trying to get the SB neopixel LEDs working but I'm out of ideas.
Currently the logo LED comes on blueish-white any time power is on, and sending any SB_led macro command causes it to blink green for a split second then back to blue-ish white. Nozzle LEDs dont come on at all.

Pin PD3 is correct for my fysetc spider 2.2 board (sb kit also fysetc), I have tried replacing board but new one had same results, there is no hotend pcb, the wires run from x carriage to spider 2.2 through the cable chains.
I tried default settings, changing to RGB (fysetc says to use this), changing to RGB and removing all references to "white" in the config, and switching default color values to see if it would change from the blue-white. Also tried adding external 5v power supply. No luck.

Is there something I'm missing?

UPDATE: The wiring was fine and config was all good, so many hours wasted! It turns out the fysetc LEDs that came with the stealthburner kit were junk, that's why it didn't work. Replaced with a $10 LED set from amazon and everything is good
Last edited:
Thank you for that information, have also the Fysetc SB kit and it is only one pixel that shines and no reaction on macros.