What's new
VORON Design

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members!

My 1st 3d printer with 350 V 2.4 R2


Well-known member
# Sexbolt Z endstop

Now it's time for Z endstop. I used sexbolt mod.


Adjusting the hight of the bolt need to be measure after mount next to the bed.

So don't tighten everything just yet.


I mounted the wrong side obviously.


A good reference for the Endstop pin.


# Klicky or not to Klicky

Now Klicky original mod. I would say you should try Klicky NG (No Glue) or Unklicky.

From my experience, this is a messy one. The glue just too messy and it just

ruined my microswitch.

The best way to put the magnet is to use magnet to push them while it is

still with other magnet. To make sure you got the right polarity.




Routing the wires to the side hole of the toolhead.




I connected to the Probe PB8, GND on EBB36.

Last edited:


Well-known member
# XY Sensorless Homing and Z endstop

I follow a couple of sensorless guides:




Since I have no knowledge about klipper or gcode.

Learning this is like walking in the dark to me.

I don't know what I should looking at. Or where to find the reference syntax or log file.

G28 X0 what it suppose to do.

I finally found that is for the SB move to the X axis to the right most to hit the frame.

In my case I put the jumper for TMC2209 for sensorless.

XY so I used PG6, PG9 pin the Red and Blue in the Diag Jumper section.


Just learned that what it mentioned in the documents said.

The most sensitivity value is 255. That's when you use G28 X0 it almost didn't move at all.

So you have to decrease the number and work your way to find the maximum number that

make it move to just single touch your frame. Gently no bank or any sound.

You have to find your sweet spot there.

Note that down.

Then go down further to find the minimum number that did not bang your frame.

Note that minimum number down.

And put the formula from the document into a spreadsheet and calculate the number you need in cfg.

Mine is

driver_SGTHRS: 97
step_pin: PF13
dir_pin: PF12 
enable_pin: !PF14
rotation_distance: 40
microsteps: 32
full_steps_per_rotation:400  #set to 400 for 0.9 degree stepper
endstop_pin: tmc2209_stepper_x:virtual_endstop
position_min: 0
position_endstop: 350
position_max: 350

homing_speed: 20   #Max 100
homing_retract_dist: 0
homing_positive_dir: true

##  Make sure to update below for your relevant driver (2208 or 2209)
[tmc2209 stepper_x]
uart_pin: PC4
interpolate: false
run_current: 0.8
sense_resistor: 0.110
stealthchop_threshold: 1
diag_pin: ^PG6
driver_SGTHRS: 97

Do the same with Y.

But for me Y was moving the wrong way to in front of the frame.

Initial setup

This link show step to take for setting up.

Look at the direction of the toolhead.

Then mine was just to "!" invert the Y.

With clee's document there are macro and homing_overide.

Thats increasing my confusing.

Especially with setting up Z endstop.

I end up crashing my toolhead to the bed badly. Crank crank crank!!!

Then I power off.

I did not know what to do. There is not much of instruction on this.

Then I figure out after manually move the toolhead to the Z pin location

and get M114 to return current location.

And I put the gcode moving manually to the location of the pin in the homing_overide.

axes: xyz
  {% set home_all = 'X' not in params and 'Y' not in params and 'Z' not in params %}

  {% if home_all or 'X' in params %}
    z_hop = 10
  {% endif %}
  {% if home_all or 'Y' in params %}
  {% endif %}
  {% if home_all or 'Z' in params %}
    G0 X222 Y349
    G28 Z0
    G1 Z10
  {% endif %}

Then it can home XYZ.

I don't know if I've done anything wrong here or not suppose to do.

I'll try the z_hop = 10 for home X today.


Well-known member
# Extruder Tuning

Follow the link:

Voron initial setup

Remove hotend put it aside. This test does not require the heat up heater.

Just need to move the motor to extrude the filament.

1st I had the motor retract instead of extruding. So I have to revert it in the printer.cfg then reboot.





Well-known member
Gotta a link to the rj11 connector with screw terminals?
Ok a lot of things going on once I jumped into the CANBUS rabbit hole.

So after I finished put together the belt and gantry and hotend.

View attachment 801

# CanBus
I started to set canboot and flash firmware for EBB36 as mentioned in the previous post.

Set the boot0 jumper on Octopus.
View attachment 802

Octopus reset button is here. Don't do the same mistake as me press the one next to the SD slot.
View attachment 803

As follow the instruction I realized that the serial id will be able to query once in DFU mode.
After that it has to use UUID acquire from the conboot query.

Put jumper VBUS on EBB36.
View attachment 804

RJ11 and HI LOW wire.
View attachment 805

I used 22AWG for the HILOW wire.


Well-known member
# PID Tuning

Following the step for PID Tuning is quite easy.

It's only when you follow the manual blindly that's gonna cost you.

My Hotend heater temp can raise very fast. The PID process took place and was done easily.

But when came to my Bed heater temp didn't buzz at all.


I was afraid the heater I got was the wrong voltage or damaged and so on..

I check all the wires and continuity again and again.

Asking every discord server as I could..

One of the discord user pointed out something from my picture.

I did swap the polarity on SSR.

I didn't check on my SSR + and - was written on it and it was different from the manual.

So I had it fixed.


Last edited:


Well-known member
# Z endstop calibration

1st I think I still couldn't have my head around the bed location and the printable area yet.

My bed size is 355x355. When it moves to 0,0 it has quite some gap over 8 mm.

But I just moved on and thought will come back for this later.

Then it came to my physical z_endstop with sexbolt.

It is troublesome when adjusting the hight pass the bed hight just a few mm.

and the closest to the be i can mount is still not at Y350 to make it center of the sexbolt.

It's now only at the outer rim of the sexbolt. It is still pressing the trigger but I can't put my eyes away when it home.

Then testing probe_accuracy.

Some timeout error it can't finish 10 times.

I had to change something in klippy.py

Changed TRSYNC_TIMEOUT value in “/home/pi/klipper/klippy/mcu.py” file from 0.025 to 0.050, i.e. was “TRSYNC_TIMEOUT = 0.025”, and became “TRSYNC_TIMEOUT = 0.050”, and the error “Communication timeout during homing probe” disappeared, and BL-Touch now works as it should. Only here there is one “BUT”…

Probe_calibrate, z_endstop_calibrate

I still don't know what probe_calibrate and z_endstop_calibrate are different from another?

Do I have to do both?



I just did z_endstop_calibrate.

Just testz z=-(number to move your toolhead down close to the bed)

Perform this with A4 paper.

Until it got close to the paper use -.1 to move a little bit at a time.

Till it starts to fit the paper then testz z=+ to move up halfway of the previous position.

Once you got the drag friction of the paper then you can accept and save_config.

For me it didn't auto update the value of endstop_position to the printer.cfg file.

I have to manually update it.

I learned this by experience. I thought it auto update the cfg for me.

And the toolhead just crash and drag my bed.

And if you can see the other mistake I made.

I did't put my magnet and PEI sheet first before doing all above.

Yes that lead to another crash and drag.

Coz those sheet gave me more mm height.

Apply the magnet sheet now.


I wish there will be more color PEI sheet in the future.


Mount plastic filament.

Honestly I wonder is there any specific way to put the PTFE tube into the SB?

Just force it in that's it?


All these I had LED issues which I don't know why it behave randomly.

Logo LED was on most of the time.

But only part LED sometimes green sometime off and then white.

And off again.

So with some answer I finally took them apart and resoldering them.

Most of my mistakes are from loose crimping, or soldering.

Last edited:


Well-known member
# My 1st Print

So with all the hard work and all the fixing and initial checks.

With the machine is still Frankenstein but it's alive.

I started to print The Cube!!!







Without belt tensioning, or anything. Pure fresh from the assembly.

I could finish the print and the result is OK for me.

It can fit the bearing.

I'm happy :).... for now..


Well-known member
# 1st Failed Print

My failed print was because I had unfinished QGL from my g32 command.

It's randomly happened to me that QGL is unable to finish. ie: buffer something too long,

or Z number increase.

Then I thought it's ok coz I had QGL many times before this.

Here we go...







Last edited:


Well-known member
Officially I could call it's real belt relocation since I've been using temp hack for a while.


But you can see the rear umbilical strain relief there later it gave me a headache too.

This mount I think it wasn't designed for EBB36. It's not a perfect fit.



Yes it snap so I couldn't print anything anymore.

So time to assemble the official mount.

As I said it wasn't designed for what I had.

I need to hack it.




Almost good till I had a mistake with the molex microfit. It is very very difficult to find in my local.

I ran out of pins for it due to many error in crimping and testing.

So another wait for my parts.


Well-known member
# Canboard mount and Umbilical mount

1st try for this mod to mount my EBB36 and umbilical with an aviation connector.






It's not perfect I can tell but I hope it could hold for a while till I find the right one.

And till I could print ABS or ASA.


It seems nice and the LED is all working now.

.... until....

It homes XYZ then a big crash...

The probe pin drags from the rear umbilical strain relief and bend it and off.

So all klicker activities failed and skip steps and crashed Z so hard..

I had to remove the rear umbilical strain relief lose for now. Till I found a solution. (Open for suggestion.)

Then I can home without hitting anything.

The canboard mount raises a few mm, dupont connector also too long.

I might have to look for a shorter stand off too.


Well-known member
While I couldn't find any solution for dupont replacement.

I decided to cut it and soldered the wire and try to bend 90 degrees for the probe pin.


Nope still not enough space.

So I go for the next to be an issue in the future. I extended the thermistor wire that I changed the connector

earlier in the build.



When putting back the SB make sure the 2 bolts at the bottom screw into the back tight and right.

My case they didn't and it make the nozzle miss location and unable to home Z to endstop properly.

Yeah another crash!! SAD


Use this opportunity to belt tensioning. I just didn't know what I"m doing just trial and error for tension.

Oh I found this happened with my nozzle overnight. What could cause this?


I couldn't remove the nozzle until now.

Use all the wrenches I had. How to do turn and remove nozzle?


Well-known member
One thing I couldn't figure it out about temp chart here.

I added 2 temp in my config hoping to show them in this chart. The octopus mcu temp and raspberry pi temp.

But it only shows the bed and extruder as u can see.

#   Thermals
[temperature_sensor Raspberrypi]

##Pi Temps
sensor_type: temperature_host
#sensor_path: /sys/class/thermal/thermal_zone0/temp
#min_temp: 0
#max_temp: 100

[temperature_sensor MCU]
##Octopus Temps
sensor_type: temperature_mcu
sensor_mcu: mcu
#min_temp: 0
#max_temp: 100

[temperature_sensor CANBOARD]
sensor_type: temperature_mcu
sensor_mcu: can0

Anyone use octoprint pls help guide me.



Well-known member
Raspberry Pi is under voltage warning that keeps happening.

I don't know if it could be any issue or not. But I kept it that way for a while.

I thought it's time to look at it now.

I have a 5V PSU and Waho connector.

I suspect is the wire for USB cable too small?



Well-known member
Raspberry Pi is under voltage warning that keeps happening.

I don't know if it could be any issue or not. But I kept it that way for a while.

I thought it's time to look at it now.

I have a 5V PSU and Waho connector.

I suspect is the wire for USB cable too small?

Measure the voltage. It has to be at least 5.1, but better if 5.2 volts. Anything less will give you an error message. Yes, it can cause issues.


Well-known member
Raspberry Pi is under voltage warning that keeps happening.

I don't know if it could be any issue or not. But I kept it that way for a while.

I thought it's time to look at it now.

I have a 5V PSU and Waho connector.

I suspect is the wire for USB cable too small?

I made 20AWG DIY USB power cable to replace the previous USB small AWG one. Under voltage warning is gone...